aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Biberhofer <sascha.biberhofer@skyforge.at>2022-09-27 17:39:36 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2022-09-29 18:08:24 +0000
commit167b320fbf10f720cd507107d1c9e1ae87b8506a (patch)
tree742ff3efbd945e0f9377619f1fbd1a01ae8d3b5f
parent823954237a966b48d3afb70d96b9898b7f520814 (diff)
downloadports-167b320fbf10f720cd507107d1c9e1ae87b8506a.tar.gz
ports-167b320fbf10f720cd507107d1c9e1ae87b8506a.zip
net-im/py-matrix-synapse: Update to 1.68.0
- This update introduces a new dependency on rust. - Testing now uses the staged build output to ensure tests run against the compiled rust module. Co-authored-by: Ashish SHUKLA <ashish@FreeBSD.org>
-rw-r--r--net-im/py-matrix-synapse/Makefile61
-rw-r--r--net-im/py-matrix-synapse/distinfo82
-rw-r--r--net-im/py-matrix-synapse/files/patch-pyproject.toml24
-rw-r--r--net-im/py-matrix-synapse/files/patch-setup.py12
4 files changed, 163 insertions, 16 deletions
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index d3188ea1eb67..0937e6310d4a 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -1,8 +1,9 @@
PORTNAME= matrix-synapse
-DISTVERSION= 1.67.0
+DISTVERSION= 1.68.0
CATEGORIES= net-im python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${DISTVERSION}.tar.gz
MAINTAINER= ports@skyforge.at
COMMENT= Matrix protocol reference homeserver
@@ -11,7 +12,8 @@ WWW= https://www.matrix.org
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3:devel/py-setuptools-rust@${PY_FLAVOR}
# Keep the RUN_DEPENDS layout similar to the master/synapse/python_dependencies.py file
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
@@ -26,7 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.9:devel/py-pyasn1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.0.7:devel/py-pyasn1-modules@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}bcrypt>=3.1.0:security/py-bcrypt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bcrypt>=3.1.7:security/py-bcrypt@${PY_FLAVOR} \
${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.4.4:devel/py-sortedcontainers@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysaml2>=4.5.0:security/py-pysaml2@${PY_FLAVOR} \
@@ -42,7 +44,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ijson>=3.1.4:devel/py-ijson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=16.1:devel/py-packaging@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}matrix-common>=1.2.1:devel/py-matrix-common@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matrix-common>=1.3.0:devel/py-matrix-common@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.7.4:devel/py-pydantic@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
@@ -53,11 +55,53 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}virtualenv>=15.0:devel/py-virtualenv@${PY_F
${PYTHON_PKGNAMEPREFIX}authlib>=0.14.0:security/py-authlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=2.5:dns/py-idna@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.7+ cargo
USE_PYTHON= autoplist distutils
USE_RC_SUBR= synapse
+CARGO_CONFIGURE= yes
+CARGO_BUILD= no
+CARGO_TEST= no
+CARGO_INSTALL= no
+CARGO_CARGOTOML= ${WRKSRC}/rust/Cargo.toml
+CARGO_CRATES= autocfg-1.1.0 \
+ bitflags-1.3.2 \
+ blake2-0.10.4 \
+ block-buffer-0.10.3 \
+ cfg-if-1.0.0 \
+ crypto-common-0.1.6 \
+ digest-0.10.5 \
+ generic-array-0.14.6 \
+ hex-0.4.3 \
+ indoc-1.0.7 \
+ libc-0.2.132 \
+ lock_api-0.4.7 \
+ once_cell-1.13.1 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.3 \
+ proc-macro2-1.0.43 \
+ pyo3-0.16.6 \
+ pyo3-build-config-0.16.6 \
+ pyo3-ffi-0.16.6 \
+ pyo3-macros-0.16.6 \
+ pyo3-macros-backend-0.16.6 \
+ quote-1.0.21 \
+ redox_syscall-0.2.16 \
+ scopeguard-1.1.0 \
+ smallvec-1.9.0 \
+ subtle-2.4.1 \
+ syn-1.0.99 \
+ target-lexicon-0.12.4 \
+ typenum-1.15.0 \
+ unicode-ident-1.0.3 \
+ unindent-0.1.10 \
+ version_check-0.9.4 \
+ windows-sys-0.36.1 \
+ windows_aarch64_msvc-0.36.1 \
+ windows_i686_gnu-0.36.1 \
+ windows_i686_msvc-0.36.1 \
+ windows_x86_64_gnu-0.36.1 \
+ windows_x86_64_msvc-0.36.1
-NO_ARCH= yes
SUB_FILES= pkg-message log.config
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} DBDIR=${DBDIR} LOGDIR=${LOGDIR} PIDDIR=${PIDDIR} USERS=${USERS}
@@ -68,7 +112,8 @@ DBDIR?= /var/db/${PORTNAME}
LOGDIR?= /var/log/${PORTNAME}
PIDDIR?= /var/run/${PORTNAME}
-PLIST_FILES= "@sample ${ETCDIR}/log.config.sample"
+PLIST_FILES= "@sample ${ETCDIR}/log.config.sample" \
+ %%PYTHON_SITELIBDIR%%/synapse/synapse_rust.abi3.so
DOCS= README.rst UPGRADE.rst CHANGES.md docs/postgres.md
PORTDOCS= ${DOCS:T}
@@ -105,6 +150,6 @@ post-install-DOCS-on:
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
do-test:
- cd ${WRKSRC} && PYTHONPATH="." trial-${PYTHON_VER} tests
+ cd ${WRKSRC} && PYTHONPATH="${STAGEDIR}/${PYTHON_SITELIBDIR}:." trial-${PYTHON_VER} tests
.include <bsd.port.post.mk>
diff --git a/net-im/py-matrix-synapse/distinfo b/net-im/py-matrix-synapse/distinfo
index 83bed5486473..f1cac32cb51f 100644
--- a/net-im/py-matrix-synapse/distinfo
+++ b/net-im/py-matrix-synapse/distinfo
@@ -1,3 +1,79 @@
-TIMESTAMP = 1663127666
-SHA256 (matrix-synapse-1.67.0.tar.gz) = f3a295bb5c14915cb5fe638d55b0ccd60f98f8a87dd32d6ba5fe7c29cd95b416
-SIZE (matrix-synapse-1.67.0.tar.gz) = 2903305
+TIMESTAMP = 1664297695
+SHA256 (matrix-synapse-1.68.0.tar.gz) = 8d0729aef2846cbb8b5ad8746967a1e668bfbfccfcdc622b8c2b26dc97497143
+SIZE (matrix-synapse-1.68.0.tar.gz) = 2931775
+SHA256 (rust/crates/autocfg-1.1.0.crate) = d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa
+SIZE (rust/crates/autocfg-1.1.0.crate) = 13272
+SHA256 (rust/crates/bitflags-1.3.2.crate) = bef38d45163c2f1dde094a7dfd33ccf595c92905c8f8f4fdc18d06fb1037718a
+SIZE (rust/crates/bitflags-1.3.2.crate) = 23021
+SHA256 (rust/crates/blake2-0.10.4.crate) = b9cf849ee05b2ee5fba5e36f97ff8ec2533916700fc0758d40d92136a42f3388
+SIZE (rust/crates/blake2-0.10.4.crate) = 46804
+SHA256 (rust/crates/block-buffer-0.10.3.crate) = 69cce20737498f97b993470a6e536b8523f0af7892a4f928cceb1ac5e52ebe7e
+SIZE (rust/crates/block-buffer-0.10.3.crate) = 10465
+SHA256 (rust/crates/cfg-if-1.0.0.crate) = baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd
+SIZE (rust/crates/cfg-if-1.0.0.crate) = 7934
+SHA256 (rust/crates/crypto-common-0.1.6.crate) = 1bfb12502f3fc46cca1bb51ac28df9d618d813cdc3d2f25b9fe775a34af26bb3
+SIZE (rust/crates/crypto-common-0.1.6.crate) = 8760
+SHA256 (rust/crates/digest-0.10.5.crate) = adfbc57365a37acbd2ebf2b64d7e69bb766e2fea813521ed536f5d0520dcf86c
+SIZE (rust/crates/digest-0.10.5.crate) = 19503
+SHA256 (rust/crates/generic-array-0.14.6.crate) = bff49e947297f3312447abdca79f45f4738097cc82b06e72054d2223f601f1b9
+SIZE (rust/crates/generic-array-0.14.6.crate) = 15889
+SHA256 (rust/crates/hex-0.4.3.crate) = 7f24254aa9a54b5c858eaee2f5bccdb46aaf0e486a595ed5fd8f86ba55232a70
+SIZE (rust/crates/hex-0.4.3.crate) = 13299
+SHA256 (rust/crates/indoc-1.0.7.crate) = adab1eaa3408fb7f0c777a73e7465fd5656136fc93b670eb6df3c88c2c1344e3
+SIZE (rust/crates/indoc-1.0.7.crate) = 13716
+SHA256 (rust/crates/libc-0.2.132.crate) = 8371e4e5341c3a96db127eb2465ac681ced4c433e01dd0e938adbef26ba93ba5
+SIZE (rust/crates/libc-0.2.132.crate) = 595317
+SHA256 (rust/crates/lock_api-0.4.7.crate) = 327fa5b6a6940e4699ec49a9beae1ea4845c6bab9314e4f84ac68742139d8c53
+SIZE (rust/crates/lock_api-0.4.7.crate) = 25371
+SHA256 (rust/crates/once_cell-1.13.1.crate) = 074864da206b4973b84eb91683020dbefd6a8c3f0f38e054d93954e891935e4e
+SIZE (rust/crates/once_cell-1.13.1.crate) = 31335
+SHA256 (rust/crates/parking_lot-0.12.1.crate) = 3742b2c103b9f06bc9fff0a37ff4912935851bee6d36f3c02bcc755bcfec228f
+SIZE (rust/crates/parking_lot-0.12.1.crate) = 40967
+SHA256 (rust/crates/parking_lot_core-0.9.3.crate) = 09a279cbf25cb0757810394fbc1e359949b59e348145c643a939a525692e6929
+SIZE (rust/crates/parking_lot_core-0.9.3.crate) = 32256
+SHA256 (rust/crates/proc-macro2-1.0.43.crate) = 0a2ca2c61bc9f3d74d2886294ab7b9853abd9c1ad903a3ac7815c58989bb7bab
+SIZE (rust/crates/proc-macro2-1.0.43.crate) = 41512
+SHA256 (rust/crates/pyo3-0.16.6.crate) = 0220c44442c9b239dd4357aa856ac468a4f5e1f0df19ddb89b2522952eb4c6ca
+SIZE (rust/crates/pyo3-0.16.6.crate) = 364587
+SHA256 (rust/crates/pyo3-build-config-0.16.6.crate) = 9c819d397859445928609d0ec5afc2da5204e0d0f73d6bf9e153b04e83c9cdc2
+SIZE (rust/crates/pyo3-build-config-0.16.6.crate) = 28891
+SHA256 (rust/crates/pyo3-ffi-0.16.6.crate) = ca882703ab55f54702d7bfe1189b41b0af10272389f04cae38fe4cd56c65f75f
+SIZE (rust/crates/pyo3-ffi-0.16.6.crate) = 60756
+SHA256 (rust/crates/pyo3-macros-0.16.6.crate) = 568749402955ad7be7bad9a09b8593851cd36e549ac90bfd44079cea500f3f21
+SIZE (rust/crates/pyo3-macros-0.16.6.crate) = 8453
+SHA256 (rust/crates/pyo3-macros-backend-0.16.6.crate) = 611f64e82d98f447787e82b8e7b0ebc681e1eb78fc1252668b2c605ffb4e1eb8
+SIZE (rust/crates/pyo3-macros-backend-0.16.6.crate) = 49252
+SHA256 (rust/crates/quote-1.0.21.crate) = bbe448f377a7d6961e30f5955f9b8d106c3f5e449d493ee1b125c1d43c2b5179
+SIZE (rust/crates/quote-1.0.21.crate) = 28030
+SHA256 (rust/crates/redox_syscall-0.2.16.crate) = fb5a58c1855b4b6819d59012155603f0b22ad30cad752600aadfcb695265519a
+SIZE (rust/crates/redox_syscall-0.2.16.crate) = 24012
+SHA256 (rust/crates/scopeguard-1.1.0.crate) = d29ab0c6d3fc0ee92fe66e2d99f700eab17a8d57d1c1d3b748380fb20baa78cd
+SIZE (rust/crates/scopeguard-1.1.0.crate) = 11470
+SHA256 (rust/crates/smallvec-1.9.0.crate) = 2fd0db749597d91ff862fd1d55ea87f7855a744a8425a64695b6fca237d1dad1
+SIZE (rust/crates/smallvec-1.9.0.crate) = 28396
+SHA256 (rust/crates/subtle-2.4.1.crate) = 6bdef32e8150c2a081110b42772ffe7d7c9032b606bc226c8260fd97e0976601
+SIZE (rust/crates/subtle-2.4.1.crate) = 12630
+SHA256 (rust/crates/syn-1.0.99.crate) = 58dbef6ec655055e20b86b15a8cc6d439cca19b667537ac6a1369572d151ab13
+SIZE (rust/crates/syn-1.0.99.crate) = 236084
+SHA256 (rust/crates/target-lexicon-0.12.4.crate) = c02424087780c9b71cc96799eaeddff35af2bc513278cda5c99fc1f5d026d3c1
+SIZE (rust/crates/target-lexicon-0.12.4.crate) = 23020
+SHA256 (rust/crates/typenum-1.15.0.crate) = dcf81ac59edc17cc8697ff311e8f5ef2d99fcbd9817b34cec66f90b6c3dfd987
+SIZE (rust/crates/typenum-1.15.0.crate) = 40741
+SHA256 (rust/crates/unicode-ident-1.0.3.crate) = c4f5b37a154999a8f3f98cc23a628d850e154479cd94decf3414696e12e31aaf
+SIZE (rust/crates/unicode-ident-1.0.3.crate) = 35031
+SHA256 (rust/crates/unindent-0.1.10.crate) = 58ee9362deb4a96cef4d437d1ad49cffc9b9e92d202b6995674e928ce684f112
+SIZE (rust/crates/unindent-0.1.10.crate) = 7703
+SHA256 (rust/crates/version_check-0.9.4.crate) = 49874b5167b65d7193b8aba1567f5c7d93d001cafc34600cee003eda787e483f
+SIZE (rust/crates/version_check-0.9.4.crate) = 14895
+SHA256 (rust/crates/windows-sys-0.36.1.crate) = ea04155a16a59f9eab786fe12a4a450e75cdb175f9e0d80da1e17db09f55b8d2
+SIZE (rust/crates/windows-sys-0.36.1.crate) = 3347053
+SHA256 (rust/crates/windows_aarch64_msvc-0.36.1.crate) = 9bb8c3fd39ade2d67e9874ac4f3db21f0d710bee00fe7cab16949ec184eeaa47
+SIZE (rust/crates/windows_aarch64_msvc-0.36.1.crate) = 661960
+SHA256 (rust/crates/windows_i686_gnu-0.36.1.crate) = 180e6ccf01daf4c426b846dfc66db1fc518f074baa793aa7d9b9aaeffad6a3b6
+SIZE (rust/crates/windows_i686_gnu-0.36.1.crate) = 818115
+SHA256 (rust/crates/windows_i686_msvc-0.36.1.crate) = e2e7917148b2812d1eeafaeb22a97e4813dfa60a3f8f78ebe204bcc88f12f024
+SIZE (rust/crates/windows_i686_msvc-0.36.1.crate) = 724575
+SHA256 (rust/crates/windows_x86_64_gnu-0.36.1.crate) = 4dcd171b8776c41b97521e5da127a2d86ad280114807d0b2ab1e462bc764d9e1
+SIZE (rust/crates/windows_x86_64_gnu-0.36.1.crate) = 790934
+SHA256 (rust/crates/windows_x86_64_msvc-0.36.1.crate) = c811ca4a8c853ef420abd8592ba53ddbbac90410fab6903b3e79972a631f7680
+SIZE (rust/crates/windows_x86_64_msvc-0.36.1.crate) = 661999
diff --git a/net-im/py-matrix-synapse/files/patch-pyproject.toml b/net-im/py-matrix-synapse/files/patch-pyproject.toml
index c8744a242c54..acbd690b99f2 100644
--- a/net-im/py-matrix-synapse/files/patch-pyproject.toml
+++ b/net-im/py-matrix-synapse/files/patch-pyproject.toml
@@ -1,6 +1,6 @@
---- pyproject.toml.orig 2022-08-02 13:44:01 UTC
+--- pyproject.toml.orig 2022-09-27 11:37:18 UTC
+++ pyproject.toml
-@@ -149,7 +149,7 @@ bleach = ">=1.4.3"
+@@ -162,7 +162,7 @@ bleach = ">=1.4.3"
typing-extensions = ">=3.10.0.1"
# We enforce that we have a `cryptography` version that bundles an `openssl`
# with the latest security patches.
@@ -8,4 +8,22 @@
+cryptography = "*"
# ijson 3.1.4 fixes a bug with "." in property names
ijson = ">=3.1.4"
- matrix-common = "^1.2.1"
+ matrix-common = "^1.3.0"
+@@ -173,17 +173,6 @@ packaging = ">=16.1"
+ importlib_metadata = { version = ">=1.4", python = "<3.8" }
+ # This is the most recent version of Pydantic with available on common distros.
+ pydantic = ">=1.7.4"
+-
+-# This is for building the rust components during "poetry install", which
+-# currently ignores the `build-system.requires` directive (c.f.
+-# https://github.com/python-poetry/poetry/issues/6154). Both `pip install` and
+-# `poetry build` do the right thing without this explicit dependency.
+-#
+-# This isn't really a dev-dependency, as `poetry install --no-dev` will fail,
+-# but the alternative is to add it to the main list of deps where it isn't
+-# needed.
+-setuptools_rust = ">=1.3"
+-
+
+ # Optional Dependencies
+ # ---------------------
diff --git a/net-im/py-matrix-synapse/files/patch-setup.py b/net-im/py-matrix-synapse/files/patch-setup.py
index 837d291cbca1..9292c52a2214 100644
--- a/net-im/py-matrix-synapse/files/patch-setup.py
+++ b/net-im/py-matrix-synapse/files/patch-setup.py
@@ -1,7 +1,7 @@
---- setup.py.orig 2022-08-02 13:44:06 UTC
+--- setup.py.orig 1970-01-01 00:00:00 UTC
+++ setup.py
@@ -149,7 +149,7 @@ install_requires = \
- 'bcrypt>=3.1.0',
+ 'bcrypt>=3.1.7',
'bleach>=1.4.3',
'canonicaljson>=1.5.0,<2.0.0',
- 'cryptography>=3.4.7',
@@ -9,3 +9,11 @@
'frozendict>=1,!=2.1.2',
'ijson>=3.1.4',
'jsonschema>=3.0.0',
+@@ -165,7 +165,6 @@ install_requires = \
+ 'pydantic>=1.7.4',
+ 'pymacaroons>=0.13.0',
+ 'service-identity>=18.1.0',
+- 'setuptools_rust>=1.3',
+ 'signedjson>=1.1.0,<2.0.0',
+ 'sortedcontainers>=1.4.4',
+ 'treq>=15.1',