aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-05 07:14:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-05 16:51:46 +0000
commit16c1136158631c2187f50243cd72a7d196975bf0 (patch)
tree4435bdea32bf7f198f5233251d841151acee46b4
parent378616b7d7fc6683d0edb11f37872314dc8229e4 (diff)
downloadports-16c1136158631c2187f50243cd72a7d196975bf0.tar.gz
ports-16c1136158631c2187f50243cd72a7d196975bf0.zip
science/py-hiphive: New port: High-order force constants for the masses
-rw-r--r--science/Makefile1
-rw-r--r--science/py-hiphive/Makefile26
-rw-r--r--science/py-hiphive/distinfo3
-rw-r--r--science/py-hiphive/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 93c7e6994ad9..3877c60b1aae 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -250,6 +250,7 @@
SUBDIR += py-gsd
SUBDIR += py-h5json
SUBDIR += py-h5py
+ SUBDIR += py-hiphive
SUBDIR += py-inequality
SUBDIR += py-jupyter_jsmol
SUBDIR += py-kim-query
diff --git a/science/py-hiphive/Makefile b/science/py-hiphive/Makefile
new file mode 100644
index 000000000000..92b0b7e38204
--- /dev/null
+++ b/science/py-hiphive/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= hiphive
+DISTVERSION= 0.7.1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High-order force constants for the masses
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numba>0:devel/py-numba@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglib>0:science/py-spglib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sympy>=1.1:math/py-sympy@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-hiphive/distinfo b/science/py-hiphive/distinfo
new file mode 100644
index 000000000000..b2891fdeb975
--- /dev/null
+++ b/science/py-hiphive/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628138471
+SHA256 (hiphive-0.7.1.tar.gz) = 4374ebc778439475d16e4b2100f4f808066a57181cc9943fbf1e44d421fabad9
+SIZE (hiphive-0.7.1.tar.gz) = 84102
diff --git a/science/py-hiphive/pkg-descr b/science/py-hiphive/pkg-descr
new file mode 100644
index 000000000000..dae73c719f8b
--- /dev/null
+++ b/science/py-hiphive/pkg-descr
@@ -0,0 +1,7 @@
+hiPhive is a tool for efficiently extracting high-order force constants from
+atomistic simulations, most commonly density functional theory calculations.
+It has been implemented in the form of a Python library, which allows it to be
+readily integrated with many first-principles codes and analysis tools
+accessible in Python.
+
+WWW: https://hiphive.materialsmodeling.org/