aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-16 20:43:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-16 20:43:56 +0000
commit16c1253b4a01641c8227b86a1d6a6072a96d37ab (patch)
tree1f3834c09bc3cad5b0c48583efd26626167dc707
parent648efac422be98b880506fc68c1cab3e68214801 (diff)
downloadports-16c1253b4a01641c8227b86a1d6a6072a96d37ab.tar.gz
ports-16c1253b4a01641c8227b86a1d6a6072a96d37ab.zip
x11/kitty: fix build on riscv64 and runtime on powerpc64
Disable LTO. On riscv64: Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi) ld: error: lto.tmp: cannot link object files with different floating-point ABI cc: error: linker command failed with exit code 1 (use -v to see invocation) On powerpc64, LTO is broken with LLVM.
-rw-r--r--x11/kitty/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11/kitty/Makefile b/x11/kitty/Makefile
index ca7a931426a5..fefa484c94a8 100644
--- a/x11/kitty/Makefile
+++ b/x11/kitty/Makefile
@@ -51,6 +51,12 @@ _STRIP_TARGETS= lib/kitty/kitty/fast_data_types.so lib/kitty/kitty/glfw-x11.so \
lib/kitty/kittens/choose/subseq_matcher.so bin/kitty
_EMPTY_DIRS= kittens/choose kittens/diff kittens/unicode_input kittens kitty
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64 || ${ARCH:Mriscv64*}
+MAKE_ENV+= KITTY_NO_LTO=1
+.endif
+
do-build:
(cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py linux-package --update-check-interval 0)