aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 17:56:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 19:27:14 +0000
commit173a5b23dbf7adc8b790e5e90ace2db2a4c26416 (patch)
tree3ea97f001d887cd0f574d4e3fe91a885f3a2f309
parent4e1d9bbd6d26b276252e6d98b98ee20dd66e4f1d (diff)
downloadports-173a5b23dbf7adc8b790e5e90ace2db2a4c26416.tar.gz
ports-173a5b23dbf7adc8b790e5e90ace2db2a4c26416.zip
emulators/visualboyadvance-m: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--emulators/visualboyadvance-m/Makefile47
1 files changed, 20 insertions, 27 deletions
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 8c0f5daeef7d..87b9355fb47c 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -15,38 +15,40 @@ LIB_DEPENDS= libpng.so:graphics/png
USES= cmake:insource,noninja dos2unix gl gnome \
pkgconfig sdl xorg
DOS2UNIX_REGEX= .*\.(c|cpp|h|ypp)
-USE_XORG= x11 xext
+USE_CXXSTD= c++11
+USE_GITHUB= yes
+GH_TAGNAME= VBA-M_Beta_2
USE_GL= gl glu
USE_SDL= sdl
+USE_XORG= x11 xext
+
CMAKE_ARGS= -DVERSION:STRING="${PORTVERSION}" \
-DSYSCONFDIR:STRING="${PREFIX}/etc" \
-DENABLE_WX:BOOL=no
-USE_GITHUB= yes
-GH_TAGNAME= VBA-M_Beta_2
-
OPTIONS_DEFINE= NLS FFMPEG LINK LIRC DEBUGGER
-OPTIONS_MULTI= INTERFACE
-OPTIONS_MULTI_INTERFACE= GVBAM SDL
OPTIONS_DEFINE_i386= ASMCORE ASMSCALERS
OPTIONS_DEFAULT= DEBUGGER SDL
+OPTIONS_MULTI= INTERFACE
+OPTIONS_MULTI_INTERFACE= GVBAM SDL
OPTIONS_SUB= yes
-GVBAM_DESC= Enable GTK interface
-SDL_DESC= Enable SDL interface
+ASMCORE_DESC= Enable x86 ASM CPU cores (i386 only)
+ASMSCALERS_DESC= Enable x86 ASM graphic filters (i386 only)
+DEBUGGER_DESC= Enable the debugger
FFMPEG_DESC= Enable FFmpeg A/V recording
+GVBAM_DESC= Enable GTK interface
LINK_DESC= Enable GBA linking functionality
LIRC_DESC= Enable LIRC infrared support
-DEBUGGER_DESC= Enable the debugger
-ASMCORE_DESC= Enable x86 ASM CPU cores (i386 only)
-ASMSCALERS_DESC= Enable x86 ASM graphic filters (i386 only)
+SDL_DESC= Enable SDL interface
ASMCORE_BUILD_DEPENDS= as:devel/binutils
ASMCORE_CMAKE_BOOL= ENABLE_ASM_CORE
-
ASMSCALERS_BUILD_DEPENDS= nasm:devel/nasm
ASMSCALERS_CMAKE_BOOL= ENABLE_ASM_SCALERS
-
+DEBUGGER_CMAKE_BOOL= ENABLE_DEBUGGER
+FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+FFMPEG_CMAKE_BOOL= ENABLE_FFMPEG
GVBAM_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgdkglext-x11-1.0.so:x11-toolkits/gtkglext \
@@ -54,24 +56,15 @@ GVBAM_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
GVBAM_USES= desktop-file-utils
GVBAM_USE= GNOME=gtkmm24,pangox-compat
GVBAM_CMAKE_BOOL= ENABLE_GTK
-
-SDL_IMPLIES= DEBUGGER
-SDL_CMAKE_BOOL= ENABLE_SDL
-
-DEBUGGER_CMAKE_BOOL= ENABLE_DEBUGGER
-
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FFMPEG_CMAKE_BOOL= ENABLE_FFMPEG
-
-NLS_USES= gettext
-NLS_CMAKE_BOOL= ENABLE_NLS
-
-LINK_CMAKE_BOOL= ENABLE_LINK
LINK_LIB_DEPENDS= libsfml-system.so:devel/sfml
-
+LINK_CMAKE_BOOL= ENABLE_LINK
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
LIRC_RUN_DEPENDS= lircd:comms/lirc
LIRC_CMAKE_BOOL= ENABLE_LIRC
+NLS_USES= gettext
+NLS_CMAKE_BOOL= ENABLE_NLS
+SDL_IMPLIES= DEBUGGER
+SDL_CMAKE_BOOL= ENABLE_SDL
.include <bsd.port.options.mk>