aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:00:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:21:35 +0000
commit17bb5136cd034bb2440cabdb78c5f4188ebd992f (patch)
treeb9895fa82d213e0385ac2de861fff93ef502a9b1
parente128044374591adb6e29a14aedfe2b92bda14894 (diff)
downloadports-17bb5136cd034bb2440cabdb78c5f4188ebd992f.tar.gz
ports-17bb5136cd034bb2440cabdb78c5f4188ebd992f.zip
lang/py-lupa: Adjust e63cf89eb69315c20b4f7e9d1d24edb002711886
-rw-r--r--lang/py-lupa/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/py-lupa/Makefile b/lang/py-lupa/Makefile
index ff0dfea4205c..202d441029ec 100644
--- a/lang/py-lupa/Makefile
+++ b/lang/py-lupa/Makefile
@@ -18,11 +18,17 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython3>=3.0.9:lang/cython3@${PY_FLAVOR} \
USES= lua pkgconfig python
USE_PYTHON= autoplist concurrent pep517 unittest
+MAKE_ARGS= --no-bundle --with-cython --with-lua-checks
+TEST_ARGS= lupa.tests.test
+
# Clean up bundled libraries
+.if !defined(MAINTAINER_MODE)
EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/third-party \
--no-same-owner --no-same-permissions
-MAKE_ARGS= --no-bundle --with-cython --with-lua-checks
-TEST_ARGS= lupa.tests.test
+.else
+post-patch:
+ @${RM} -r ${WRKSRC}/third-party/
+.endif
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +