aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-05-21 02:57:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-05-21 03:13:59 +0000
commit1885fe5b0cd69e136a5bf5e51cd203dfdc44c37d (patch)
tree7689784e74d8cdc4b9c6b976b30c4b063b219ea3
parentefcc1dce2e6b708579bec796d5c62077be3b9406 (diff)
downloadports-1885fe5b0cd69e136a5bf5e51cd203dfdc44c37d.tar.gz
ports-1885fe5b0cd69e136a5bf5e51cd203dfdc44c37d.zip
graphics/libplacebo: unbreak GLSLANG=on after 1801dc29cec9
compiler.find_library(static: true) ignores LDFLAGS and LIBRARY_PATH as Meson uses --print-search-dirs instead of trying to link. src/glsl/meson.build:34:4: ERROR: C++ static library 'SPIRV' not found src/glsl/meson.build:45:12: ERROR: C++ static library 'MachineIndependent' not found PR: 270221 Reported by: Philipp Ost Regressed by: https://code.videolan.org/videolan/libplacebo/-/commit/980f2574aa0f (cherry picked from commit 506f67ea200f6858dd4f49efb28ccdd33456e0d9)
-rw-r--r--graphics/libplacebo/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/libplacebo/Makefile b/graphics/libplacebo/Makefile
index 220a7927fd5d..cc4a7928ac08 100644
--- a/graphics/libplacebo/Makefile
+++ b/graphics/libplacebo/Makefile
@@ -54,6 +54,9 @@ VULKAN_MESON_ENABLED= vulkan
post-patch:
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
${WRKSRC}/src/vulkan/utils_gen.py
+# https://github.com/mesonbuild/meson/issues/7746
+ @${REINPLACE_CMD} "s,static:,dirs: '${LOCALBASE}/lib'\, &," \
+ ${WRKSRC}/src/glsl/meson.build
# Extract (snapshot) version from port version instead of meson.build
@${REINPLACE_CMD} "s/version_pretty/'${DISTVERSIONFULL}'/" \
${WRKSRC}/src/meson.build