aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-19 11:20:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-19 13:46:26 +0000
commit194fda4858ba75fd4d4e4b2866b6f739c2988f40 (patch)
tree8bde6f013e76c554051ea2beeec005180574f797
parent8417eee440bf6e076652512123d5f9c6490c67ef (diff)
downloadports-194fda4858ba75fd4d4e4b2866b6f739c2988f40.tar.gz
ports-194fda4858ba75fd4d4e4b2866b6f739c2988f40.zip
devel/love08: fix build
-rw-r--r--devel/love08/Makefile2
-rw-r--r--devel/love08/files/patch-src_libraries_Box2D_Collision_Shapes_b2ChainShape.h13
-rw-r--r--devel/love08/files/patch-src_modules_graphics_opengl_Canvas.cpp10
-rw-r--r--devel/love08/files/patch-src_modules_graphics_opengl_Graphics.cpp10
-rw-r--r--devel/love08/files/patch-src_modules_graphics_opengl_PixelEffect.cpp10
-rw-r--r--devel/love08/files/patch-src_modules_graphics_opengl_VertexBuffer.cpp10
6 files changed, 53 insertions, 2 deletions
diff --git a/devel/love08/Makefile b/devel/love08/Makefile
index 704a3af371ef..f3f0594db8dc 100644
--- a/devel/love08/Makefile
+++ b/devel/love08/Makefile
@@ -10,8 +10,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-BROKEN= fails to build
-
LIB_DEPENDS= libIL.so:graphics/devil \
libmodplug.so:audio/libmodplug \
libmpg123.so:audio/mpg123 \
diff --git a/devel/love08/files/patch-src_libraries_Box2D_Collision_Shapes_b2ChainShape.h b/devel/love08/files/patch-src_libraries_Box2D_Collision_Shapes_b2ChainShape.h
new file mode 100644
index 000000000000..5b74f207c931
--- /dev/null
+++ b/devel/love08/files/patch-src_libraries_Box2D_Collision_Shapes_b2ChainShape.h
@@ -0,0 +1,13 @@
+--- src/libraries/Box2D/Collision/Shapes/b2ChainShape.h.orig 2012-04-06 18:15:01 UTC
++++ src/libraries/Box2D/Collision/Shapes/b2ChainShape.h
+@@ -95,8 +95,8 @@ inline b2ChainShape::b2ChainShape()
+ m_radius = b2_polygonRadius;
+ m_vertices = NULL;
+ m_count = 0;
+- m_hasPrevVertex = NULL;
+- m_hasNextVertex = NULL;
++ m_hasPrevVertex = false;
++ m_hasNextVertex = false;
+ }
+
+ #endif
diff --git a/devel/love08/files/patch-src_modules_graphics_opengl_Canvas.cpp b/devel/love08/files/patch-src_modules_graphics_opengl_Canvas.cpp
new file mode 100644
index 000000000000..fcca7b15eabd
--- /dev/null
+++ b/devel/love08/files/patch-src_modules_graphics_opengl_Canvas.cpp
@@ -0,0 +1,10 @@
+--- src/modules/graphics/opengl/Canvas.cpp.orig 2012-04-06 18:15:01 UTC
++++ src/modules/graphics/opengl/Canvas.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "Canvas.h"
+ #include "Graphics.h"
+ #include <common/Matrix.h>
diff --git a/devel/love08/files/patch-src_modules_graphics_opengl_Graphics.cpp b/devel/love08/files/patch-src_modules_graphics_opengl_Graphics.cpp
new file mode 100644
index 000000000000..37747e8eea39
--- /dev/null
+++ b/devel/love08/files/patch-src_modules_graphics_opengl_Graphics.cpp
@@ -0,0 +1,10 @@
+--- src/modules/graphics/opengl/Graphics.cpp.orig 2012-04-06 18:15:01 UTC
++++ src/modules/graphics/opengl/Graphics.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include <common/config.h>
+ #include <common/math.h>
+ #include <common/Vector.h>
diff --git a/devel/love08/files/patch-src_modules_graphics_opengl_PixelEffect.cpp b/devel/love08/files/patch-src_modules_graphics_opengl_PixelEffect.cpp
new file mode 100644
index 000000000000..0142ea8c9d0d
--- /dev/null
+++ b/devel/love08/files/patch-src_modules_graphics_opengl_PixelEffect.cpp
@@ -0,0 +1,10 @@
+--- src/modules/graphics/opengl/PixelEffect.cpp.orig 2012-04-06 18:15:01 UTC
++++ src/modules/graphics/opengl/PixelEffect.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "PixelEffect.h"
+ #include "GLee.h"
+
diff --git a/devel/love08/files/patch-src_modules_graphics_opengl_VertexBuffer.cpp b/devel/love08/files/patch-src_modules_graphics_opengl_VertexBuffer.cpp
new file mode 100644
index 000000000000..4a88fda8a26a
--- /dev/null
+++ b/devel/love08/files/patch-src_modules_graphics_opengl_VertexBuffer.cpp
@@ -0,0 +1,10 @@
+--- src/modules/graphics/opengl/VertexBuffer.cpp.orig 2012-04-06 18:15:01 UTC
++++ src/modules/graphics/opengl/VertexBuffer.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "VertexBuffer.h"
+
+ #include "common/Exception.h"