aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2023-04-26 13:08:30 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-04-29 17:15:14 +0000
commit19fab59233f0528f86fb886f08f2581929c39200 (patch)
treeab5e7856878aa26eccfbdad3538cdef60b72774e
parent183fb0ff4251abbd31a0a151556108b5c2e1d190 (diff)
downloadports-19fab59233f0528f86fb886f08f2581929c39200.tar.gz
ports-19fab59233f0528f86fb886f08f2581929c39200.zip
multimedia/openshot: Update to 3.1.1
ChangeLog: https://www.openshot.org/blog/2023/04/20/new_openshot_release_311/ * Fixes and Improvements to Tracker and Object Detection effects (fix property editing, prevent crashes, removed black background) * Fixes to Parent property (simplify context menus, a single None option, include thumbnail images) * Prevent freeze on launch (when OpenShot's sample rate does not match the default Windows sample rate) * Adding Profile Search button to Preferences (for easier filtering and searching for a default profile) * Fix duplicate Profile name bug (causing an issue when exporting and re-opening a project with certain duplicate profile names) * Protect timeline (webview) from receiving lots of unneeded messages from libopenshot (prevents crash in certain cases) * Improved caching logic around Property Editor (better performance while adjusting clip properties) * Fix large memory leak in Clip::Close() method (not correctly clearing Clip cache) * Prevent crash on timeline::SetCache (adding thread lock) * Adding additional logging around audio device detection and initialization * Allow audio-only clips to be transparent (revealing the video/image of clips below them) * Multiple fixes for WebM decoding (preventing freezes and crashes) * Fix divide by zero error in AudioWaveformer (if no amplitude was found) * Fix GitHub actions to remove Ubuntu 18.04 builder and some additional tweaks to build scripts * Many small code refactors and fixes to prevent noisy errors (reported by Sentry.io) * Minimum libopenshot C++ dependency set to 0.3.2 * Updated language translations * Updated credits and donors PR: 271075 Reported by: tatsuki_makino@hotmail.com (maintainer)
-rw-r--r--multimedia/openshot/Makefile5
-rw-r--r--multimedia/openshot/distinfo6
-rw-r--r--multimedia/openshot/files/patch-src_classes_language.py14
-rw-r--r--multimedia/openshot/files/patch-src_windows_preferences.py4
-rw-r--r--multimedia/openshot/pkg-plist10
5 files changed, 26 insertions, 13 deletions
diff --git a/multimedia/openshot/Makefile b/multimedia/openshot/Makefile
index 9c96540bd4c5..66fd4b0cdf45 100644
--- a/multimedia/openshot/Makefile
+++ b/multimedia/openshot/Makefile
@@ -1,7 +1,6 @@
PORTNAME= openshot
DISTVERSIONPREFIX= v
-DISTVERSION= 3.1.0
-PORTREVISION= 2
+DISTVERSION= 3.1.1
CATEGORIES= multimedia
MAINTAINER= tatsuki_makino@hotmail.com
@@ -12,7 +11,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libopenshot>=0.3.1:multimedia/libopenshot@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libopenshot>=0.3.2:multimedia/libopenshot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sentry-sdk>=0:devel/py-sentry-sdk@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyzmq>=0:net/py-pyzmq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}distro>=0:sysutils/py-distro@${PY_FLAVOR} \
diff --git a/multimedia/openshot/distinfo b/multimedia/openshot/distinfo
index 19dea14df8a5..efef469bad4c 100644
--- a/multimedia/openshot/distinfo
+++ b/multimedia/openshot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681095600
-SHA256 (OpenShot-openshot-qt-v3.1.0_GH0.tar.gz) = 0522bd6c7d2b254e598d0ed53e7b6b8d7af566e6242f1d2af22c281807fc3f9a
-SIZE (OpenShot-openshot-qt-v3.1.0_GH0.tar.gz) = 95780829
+TIMESTAMP = 1682218800
+SHA256 (OpenShot-openshot-qt-v3.1.1_GH0.tar.gz) = 2b67cb4fc78863911b0263364240947b6331a976aad74943e8f6e46221b52e91
+SIZE (OpenShot-openshot-qt-v3.1.1_GH0.tar.gz) = 95843738
diff --git a/multimedia/openshot/files/patch-src_classes_language.py b/multimedia/openshot/files/patch-src_classes_language.py
new file mode 100644
index 000000000000..04248014eb65
--- /dev/null
+++ b/multimedia/openshot/files/patch-src_classes_language.py
@@ -0,0 +1,14 @@
+--- src/classes/language.py.orig 2023-04-20 05:27:15 UTC
++++ src/classes/language.py
+@@ -101,7 +101,10 @@ def init_language():
+ log.info("Language overridden on command line, using: {}".format(info.CMDLINE_LANGUAGE))
+
+ # Default the locale to C, for number formatting
+- locale.setlocale(locale.LC_ALL, 'C')
++ if ".UTF-8" in locale.setlocale(locale.LC_ALL):
++ locale.setlocale(locale.LC_ALL, 'C.UTF-8')
++ else:
++ locale.setlocale(locale.LC_ALL, 'C')
+
+ # Loop through environment variables
+ found_language = False
diff --git a/multimedia/openshot/files/patch-src_windows_preferences.py b/multimedia/openshot/files/patch-src_windows_preferences.py
index b361734d20b5..c0dc577ef5cb 100644
--- a/multimedia/openshot/files/patch-src_windows_preferences.py
+++ b/multimedia/openshot/files/patch-src_windows_preferences.py
@@ -1,6 +1,6 @@
---- src/windows/preferences.py.orig 2023-04-01 07:04:04 UTC
+--- src/windows/preferences.py.orig 2023-04-20 05:27:15 UTC
+++ src/windows/preferences.py
-@@ -318,7 +318,7 @@ class Preferences(QDialog):
+@@ -325,7 +325,7 @@ class Preferences(QDialog):
value_list.remove(value_item)
elif os_platform == "Windows" and v not in ("0", "3", "4"):
value_list.remove(value_item)
diff --git a/multimedia/openshot/pkg-plist b/multimedia/openshot/pkg-plist
index b15af20c4c19..1778a4cbf66e 100644
--- a/multimedia/openshot/pkg-plist
+++ b/multimedia/openshot/pkg-plist
@@ -1,9 +1,9 @@
bin/openshot-qt
-%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.0-py%%PYTHON_VER%%.egg-info/PKG-INFO
-%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.0-py%%PYTHON_VER%%.egg-info/SOURCES.txt
-%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.0-py%%PYTHON_VER%%.egg-info/dependency_links.txt
-%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.0-py%%PYTHON_VER%%.egg-info/entry_points.txt
-%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.0-py%%PYTHON_VER%%.egg-info/top_level.txt
+%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.1-py%%PYTHON_VER%%.egg-info/PKG-INFO
+%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.1-py%%PYTHON_VER%%.egg-info/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.1-py%%PYTHON_VER%%.egg-info/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.1-py%%PYTHON_VER%%.egg-info/entry_points.txt
+%%PYTHON_SITELIBDIR%%/openshot_qt-3.1.1-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/openshot_qt/__init__.py
%%PYTHON_SITELIBDIR%%/openshot_qt/__pycache__/__init__%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
%%PYTHON_SITELIBDIR%%/openshot_qt/__pycache__/__init__%%PYTHON_EXT_SUFFIX%%.pyc