aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-31 11:13:07 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-31 11:13:07 +0000
commit1a1f2fbd6ccefa2eb32a6966b0ec5c7ab4283985 (patch)
tree9aa942353cbbeaf9982a3a4c4cdfb98bcb5fb4d1
parentfaa2c926ca213a7e688bf0993338f9c569275a7f (diff)
downloadports-1a1f2fbd6ccefa2eb32a6966b0ec5c7ab4283985.tar.gz
ports-1a1f2fbd6ccefa2eb32a6966b0ec5c7ab4283985.zip
math/fftw3: fix altivec check
MACHINE_CPU is actually empty on powerpc* so just enable altivec on powerpc64*, which should have altivec anyway.
-rw-r--r--math/fftw3/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 5c1f93409379..74e7e520b405 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -94,7 +94,7 @@ CONFIGURE_ARGS+=--enable-avx2 --enable-fma
. if !empty(MACHINE_CPU:Msse)
CONFIGURE_ARGS+=--enable-sse2
. endif
-. if !empty(ARCH:Mpowerpc*) && !empty(MACHINE_CPU:Maltivec)
+. if !empty(ARCH:Mpowerpc64*)
CONFIGURE_ARGS+=--enable-altivec
. endif
. if ${ARCH} == "aarch64"