aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-18 12:47:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-18 12:47:56 +0000
commit1ad752f994a971f926d58369d0d424c9834f659c (patch)
treec8b814b576e6e69e81564638ae605df5094baea7
parent5026dc80a146e05f2c6d4359b44ca47b3142f2b0 (diff)
downloadports-1ad752f994a971f926d58369d0d424c9834f659c.tar.gz
ports-1ad752f994a971f926d58369d0d424c9834f659c.zip
audio/libmad: Update to 0.16.4
- Update MASTER_SITES - Fix LICENSE - Update COMMENT - Update WWW - Update pkg-descr - Clean up libmad.pc patch from dependent ports Changes: https://codeberg.org/tenacityteam/libmad/releases
-rw-r--r--audio/libmad/Makefile11
-rw-r--r--audio/libmad/distinfo6
-rw-r--r--audio/libmad/files/patch-CMakeLists.txt11
-rw-r--r--audio/libmad/pkg-descr16
-rw-r--r--audio/libmad/pkg-plist2
5 files changed, 19 insertions, 27 deletions
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
index 5613b9b6b8ff..d1bff9370777 100644
--- a/audio/libmad/Makefile
+++ b/audio/libmad/Makefile
@@ -1,13 +1,14 @@
PORTNAME= libmad
-PORTVERSION= 0.16.3
+PORTVERSION= 0.16.4
CATEGORIES= audio
-MASTER_SITES= https://codeberg.org/tenacityteam/libmad/archive/${PORTVERSION}${EXTRACT_SUFX}?dummy=/
+MASTER_SITES= https://codeberg.org/tenacityteam/libmad/releases/download/${PORTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Libmad library (part of MAD project)
-WWW= https://www.underbit.com/products/mad/
+COMMENT= MPEG audio decoder library
+WWW= https://www.underbit.com/products/mad/ \
+ https://codeberg.org/tenacityteam/libmad
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake cpe pathfix
diff --git a/audio/libmad/distinfo b/audio/libmad/distinfo
index d53cb1e89dad..249406a0f14c 100644
--- a/audio/libmad/distinfo
+++ b/audio/libmad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679007535
-SHA256 (libmad-0.16.3.tar.gz) = 228bc0ea47d22ee70c087e7289e2c620829204972c9fe6ea8951ecf6c39d8966
-SIZE (libmad-0.16.3.tar.gz) = 204230
+TIMESTAMP = 1713033308
+SHA256 (libmad-0.16.4.tar.gz) = 0f6bfb36c554075494b5fc2c646d08de7364819540f23bab30ae73fa1b5cfe65
+SIZE (libmad-0.16.4.tar.gz) = 921048
diff --git a/audio/libmad/files/patch-CMakeLists.txt b/audio/libmad/files/patch-CMakeLists.txt
deleted file mode 100644
index c491e9e9ee97..000000000000
--- a/audio/libmad/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2022-06-22 22:48:45 UTC
-+++ CMakeLists.txt
-@@ -35,7 +35,7 @@ endif()
-
- set_target_properties(mad PROPERTIES
- VERSION ${CMAKE_PROJECT_VERSION}
-- SOVERSION ${CMAKE_PROJECT_VERSION}
-+ SOVERSION 0
- )
-
- #
diff --git a/audio/libmad/pkg-descr b/audio/libmad/pkg-descr
index 2bb5e2b22998..43facb4056b7 100644
--- a/audio/libmad/pkg-descr
+++ b/audio/libmad/pkg-descr
@@ -1,7 +1,7 @@
-MAD is a high-quality MPEG audio decoder. It currently supports MPEG-1 and the
-MPEG-2 extension to lower sampling frequencies, as well as the de facto MPEG 2.5
-format. All three audio layers -- Layer I, Layer II, and Layer III (i.e. MP3) --
-are fully implemented.
+MAD (libmad) is a high-quality MPEG audio decoder. It currently supports MPEG-1
+and the MPEG-2 extension to Lower Sampling Frequencies, as well as the so-called
+MPEG 2.5 format. All three audio layers (Layer I, Layer II, and Layer III a.k.a.
+MP3) are fully implemented.
MAD does not yet support MPEG-2 multichannel audio (although it should be
backward compatible with such streams) nor does it currently support AAC.
@@ -10,7 +10,9 @@ MAD has the following special features:
- 24-bit PCM output
- 100% fixed-point (integer) computation
- completely new implementation based on the ISO/IEC standards
-- available under the terms of the GNU General Public License (GPL)
+- distributed under the terms of the GNU General Public License (GPL)
-The software is distributed as a library (libmad) and command-line front-end
-(madplay). Also included is an ID3 tag manipulation library (libid3tag).
+Because MAD provides full 24-bit PCM output, applications using MAD are able to
+produce high quality audio. Even when the output device supports only 16-bit
+PCM, applications can use the extra resolution to increase the audible dynamic
+range through the use of dithering or noise shaping.
diff --git a/audio/libmad/pkg-plist b/audio/libmad/pkg-plist
index 248de4e593fc..f6870992ccfc 100644
--- a/audio/libmad/pkg-plist
+++ b/audio/libmad/pkg-plist
@@ -6,4 +6,4 @@ lib/cmake/mad/madTargets.cmake
lib/libmad.so
lib/libmad.so.0
lib/libmad.so.%%PORTVERSION%%
-libdata/pkgconfig/libmad.pc
+libdata/pkgconfig/mad.pc