aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2023-09-28 18:36:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2023-09-28 19:34:41 +0000
commit1b1a9642a2bcb72ea37f922ce50dd71ce84ead7a (patch)
treea42959d6047c55b656f6e61f63000c97d641094e
parent93ff2ebe0ae29345896441e0d2e114945768ac28 (diff)
downloadports-1b1a9642a2bcb72ea37f922ce50dd71ce84ead7a.tar.gz
ports-1b1a9642a2bcb72ea37f922ce50dd71ce84ead7a.zip
devel/bennugd-modules: fix build with clang16, add missing USES=xorg
-rw-r--r--devel/bennugd-modules/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/bennugd-modules/Makefile b/devel/bennugd-modules/Makefile
index 18f94edeb348..06bbb58114c0 100644
--- a/devel/bennugd-modules/Makefile
+++ b/devel/bennugd-modules/Makefile
@@ -13,14 +13,16 @@ WWW= https://www.bennugd.org/
LIB_DEPENDS= libbgdrtm.so:devel/bennugd-core \
libpng.so:graphics/png
-USES= dos2unix libtool pkgconfig sdl tar:bzip2
+USES= dos2unix libtool pkgconfig sdl tar:bzip2 xorg
USE_SDL= sdl mixer
+USE_XORG= x11
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/bennugd"
DOS2UNIX_GLOB= *.c
INSTALL_TARGET= install-strip
+CFLAGS+= -Wno-incompatible-function-pointer-types -Wno-int-conversion
WRKSRC= ${WRKDIR}/bennugd/${PORTNAME}