aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2024-01-30 06:30:11 +0000
committerXin LI <delphij@FreeBSD.org>2024-01-30 06:30:58 +0000
commit1b62e1ba6fb26172e0ab8f1e76af0405ac493d71 (patch)
treeefe94fb3a7b97dcd30740ce00f3ffb797b8fc2e0
parent4df670b471998621041d14c4a6d17f8b2ef5e089 (diff)
downloadports-1b62e1ba6fb26172e0ab8f1e76af0405ac493d71.tar.gz
ports-1b62e1ba6fb26172e0ab8f1e76af0405ac493d71.zip
net/openldap25-server: upgrade to 2.5.17.
-rw-r--r--net/openldap25-server/Makefile6
-rw-r--r--net/openldap25-server/distinfo6
-rw-r--r--net/openldap25-server/files/patch-libraries__libldap__Makefile.in4
-rw-r--r--net/openldap25-server/files/patch-libraries_libldap_tls__o.c12
-rw-r--r--net/openldap25-server/files/patch-servers_lloadd_libevent__support.c32
-rw-r--r--net/openldap25-server/files/patch-servers_lloadd_module__init.c18
6 files changed, 14 insertions, 64 deletions
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index 8ade4699935e..f275ebbc9b60 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -1,5 +1,5 @@
PORTNAME= openldap
-DISTVERSION= 2.5.16
+DISTVERSION= 2.5.17
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= https://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/ \
@@ -45,9 +45,9 @@ CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-server ${PORTNAME}-server
GNU_CONFIGURE= yes
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 1
+PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 0
-OPENLDAP_SHLIB_MINOR= 1.11
+OPENLDAP_SHLIB_MINOR= 1.12
OPENLDAP_MAJOR= ${DISTVERSION:R}
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
diff --git a/net/openldap25-server/distinfo b/net/openldap25-server/distinfo
index 4fcfbaa8c8ed..348bd30e5b64 100644
--- a/net/openldap25-server/distinfo
+++ b/net/openldap25-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1691645240
-SHA256 (openldap-2.5.16.tgz) = 546ba591822e8bb0e467d40c4d4a30f89d937c3a507fe83a578f582f6a211327
-SIZE (openldap-2.5.16.tgz) = 6455656
+TIMESTAMP = 1706595143
+SHA256 (openldap-2.5.17.tgz) = d706a34b348ae38a9e3e4eb0d2cd5afeb939f2b2db95e6ae3d410d6a75e90e3c
+SIZE (openldap-2.5.17.tgz) = 6461889
diff --git a/net/openldap25-server/files/patch-libraries__libldap__Makefile.in b/net/openldap25-server/files/patch-libraries__libldap__Makefile.in
index 551b567191b2..d8a203f7b4c2 100644
--- a/net/openldap25-server/files/patch-libraries__libldap__Makefile.in
+++ b/net/openldap25-server/files/patch-libraries__libldap__Makefile.in
@@ -1,6 +1,6 @@
---- libraries/libldap/Makefile.in.orig 2021-07-27 17:44:47 UTC
+--- libraries/libldap/Makefile.in.orig 2024-01-29 18:53:15 UTC
+++ libraries/libldap/Makefile.in
-@@ -86,13 +86,6 @@ install-local: $(CFFILES) FORCE
+@@ -84,13 +84,6 @@ install-local: $(CFFILES) FORCE
$(LTFINISH) $(DESTDIR)$(libdir)
-$(MKDIR) $(DESTDIR)$(sysconfdir)
@for i in $(CFFILES); do \
diff --git a/net/openldap25-server/files/patch-libraries_libldap_tls__o.c b/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
index 3c9bccd4dc15..563d964041a8 100644
--- a/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
+++ b/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
@@ -1,6 +1,6 @@
---- libraries/libldap/tls_o.c.orig 2021-07-27 17:44:47 UTC
+--- libraries/libldap/tls_o.c.orig 2024-01-29 18:53:15 UTC
+++ libraries/libldap/tls_o.c
-@@ -275,7 +275,7 @@ tlso_ctx_free ( tls_ctx *ctx )
+@@ -279,7 +279,7 @@ tlso_ctx_free ( tls_ctx *ctx )
SSL_CTX_free( c );
}
@@ -9,12 +9,12 @@
static char *
tlso_stecpy( char *dst, const char *src, const char *end )
{
-@@ -411,7 +411,7 @@ tlso_ctx_init( struct ldapoptions *lo, struct ldaptls
- }
+@@ -425,7 +425,7 @@ tlso_ctx_init( struct ldapoptions *lo, struct ldaptls
if ( lo->ldo_tls_ciphersuite ) {
+ char *oldsuites = lt->lt_ciphersuite;
-#if OPENSSL_VERSION_NUMBER >= 0x10101000
+#if OPENSSL_VERSION_NUMBER >= 0x10101000 && !defined(OPENSSL_NO_TLS1_3)
- tlso_ctx_cipher13( ctx, lt->lt_ciphersuite );
+ tlso_ctx_cipher13( ctx, lt->lt_ciphersuite, &oldsuites );
#endif
- if ( !SSL_CTX_set_cipher_list( ctx, lt->lt_ciphersuite ) )
+ if ( oldsuites && !SSL_CTX_set_cipher_list( ctx, oldsuites ) )
diff --git a/net/openldap25-server/files/patch-servers_lloadd_libevent__support.c b/net/openldap25-server/files/patch-servers_lloadd_libevent__support.c
deleted file mode 100644
index bca9a5b7a3ff..000000000000
--- a/net/openldap25-server/files/patch-servers_lloadd_libevent__support.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- servers/lloadd/libevent_support.c.orig 2023-02-08 18:49:18 UTC
-+++ servers/lloadd/libevent_support.c
-@@ -131,6 +131,20 @@ lload_libevent_cond_timedwait(
- return ldap_pvt_thread_cond_wait( cond, mutex );
- }
-
-+/*
-+ * libevent2 expects the thread id has a type of unsigned long.
-+ */
-+static unsigned long
-+lload_libevent_thread_self(void)
-+{
-+ unsigned long retval;
-+ static_assert(sizeof(ldap_pvt_thread_t) <= sizeof(unsigned long),
-+ "ldap_pvt_thread_t has to be smaller or equal to unsigned long");
-+
-+ retval = (unsigned long)ldap_pvt_thread_self();
-+ return (retval);
-+}
-+
- int
- lload_libevent_init( void )
- {
-@@ -160,7 +174,7 @@ lload_libevent_init( void )
-
- evthread_set_lock_callbacks( &cbs );
- evthread_set_condition_callbacks( &cond_cbs );
-- evthread_set_id_callback( ldap_pvt_thread_self );
-+ evthread_set_id_callback( lload_libevent_thread_self );
- return 0;
- }
-
diff --git a/net/openldap25-server/files/patch-servers_lloadd_module__init.c b/net/openldap25-server/files/patch-servers_lloadd_module__init.c
deleted file mode 100644
index 17fb5bd179cd..000000000000
--- a/net/openldap25-server/files/patch-servers_lloadd_module__init.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- servers/lloadd/module_init.c.orig 2023-02-08 18:49:18 UTC
-+++ servers/lloadd/module_init.c
-@@ -145,14 +145,13 @@ lload_back_initialize( BackendInfo *bi )
- {
- bi->bi_flags = SLAP_BFLAG_STANDALONE;
- bi->bi_open = lload_back_open;
-- bi->bi_config = config_generic_wrapper;
- bi->bi_pause = lload_pause_cb;
- bi->bi_unpause = lload_unpause_cb;
- bi->bi_close = lload_back_close;
- bi->bi_destroy = 0;
-
- bi->bi_db_init = 0;
-- bi->bi_db_config = 0;
-+ bi->bi_db_config = config_generic_wrapper;
- bi->bi_db_open = 0;
- bi->bi_db_close = 0;
- bi->bi_db_destroy = 0;