aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-07 03:50:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-07 03:51:43 +0000
commit1bcb65d29c3f9a78b9ba24f85313ff0036de424a (patch)
tree01e78234ad4fc9a1fa3ee6e6240adad74907abaf
parent1d89d5720bcbbd5e6e496d328f7dfe1c325e99e4 (diff)
downloadports-1bcb65d29c3f9a78b9ba24f85313ff0036de424a.tar.gz
ports-1bcb65d29c3f9a78b9ba24f85313ff0036de424a.zip
misc/usd: Chase extra FreeBSD patches; Add NOT_FOR_ARCHS line; Add the test target
-rw-r--r--misc/usd/Makefile13
-rw-r--r--misc/usd/distinfo6
2 files changed, 14 insertions, 5 deletions
diff --git a/misc/usd/Makefile b/misc/usd/Makefile
index e33a0327221c..312cd81f31b9 100644
--- a/misc/usd/Makefile
+++ b/misc/usd/Makefile
@@ -1,10 +1,11 @@
PORTNAME= usd
DISTVERSIONPREFIX= v
DISTVERSION= 21.11
+PORTREVISION= 1
CATEGORIES= misc
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= 8fb0221e16920d8c1ec4bd695d83f605be36f8c3.patch:-p1
+PATCHFILES= 4942189cf7b1a45b23d62f4ae92a940721ec4009.patch:-p1
MAINTAINER= yuri@FreeBSD.org
COMMENT= Universal Scene Description is a scene description management system
@@ -12,9 +13,11 @@ COMMENT= Universal Scene Description is a scene description management system
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+NOT_FOR_ARCHS= i386 # CMakeLists.txt fails for non-64-bit architectures
+
LIB_DEPENDS= libtbb.so:devel/tbb
-USES= cmake
+USES= cmake python:test
USE_GITHUB= yes
GH_ACCOUNT= PixarAnimationStudios
@@ -35,4 +38,10 @@ TOOLS_DESC= Build commandline tools
TOOLS_CMAKE_BOOL= PXR_BUILD_USD_TOOLS
TOOLS_LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
+do-test: # tests are expected to be installed, see https://github.com/PixarAnimationStudios/USD/issues/1707
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DPXR_BUILD_TESTS=ON -DPYTHON_EXECUTABLE=${PYTHON_CMD} ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} install && \
+ ctest -C ${CMAKE_BUILD_TYPE} ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/misc/usd/distinfo b/misc/usd/distinfo
index 6df9b73e32a0..23e4eb794900 100644
--- a/misc/usd/distinfo
+++ b/misc/usd/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1638739003
+TIMESTAMP = 1638821145
SHA256 (PixarAnimationStudios-USD-v21.11_GH0.tar.gz) = 7adfde17b8ee294ee7002edb240555c61b5135fa215a7252b2a8e291bb9c4b44
SIZE (PixarAnimationStudios-USD-v21.11_GH0.tar.gz) = 29844452
-SHA256 (8fb0221e16920d8c1ec4bd695d83f605be36f8c3.patch) = 3f4719ab467ed7b1fb34e038134c44c369872d5f70aaf53484cd75a1ce7be32d
-SIZE (8fb0221e16920d8c1ec4bd695d83f605be36f8c3.patch) = 44965
+SHA256 (4942189cf7b1a45b23d62f4ae92a940721ec4009.patch) = b53487285f28a163f7f39549fbe3b9cb743fd401570565df2466cbf357538990
+SIZE (4942189cf7b1a45b23d62f4ae92a940721ec4009.patch) = 46383