aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-04-18 23:53:40 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-04-18 23:57:12 +0000
commit1c1cb5e96547b6240f3dd652ab953f91e492c3f2 (patch)
tree652febf3bab48bd179dd6d1bf2123e1e13174ba0
parent2f93f1503c5e753dfe7f63de0a3792c131a71e48 (diff)
downloadports-1c1cb5e96547b6240f3dd652ab953f91e492c3f2.tar.gz
ports-1c1cb5e96547b6240f3dd652ab953f91e492c3f2.zip
devel/llvm18: 18.1.4 release
Release notes: https://discourse.llvm.org/t/18-1-4-released/78430 Allow sanitizers to link without -lsys. Sponsored by: AFRL, DARPA
-rw-r--r--devel/llvm18/Makefile2
-rw-r--r--devel/llvm18/distinfo6
-rw-r--r--devel/llvm18/files/patch-compiler-rt_lib_sanitizer__common_sanitizer__linux__libcdep.cpp11
3 files changed, 15 insertions, 4 deletions
diff --git a/devel/llvm18/Makefile b/devel/llvm18/Makefile
index f28a46370c65..0eddea69ebf1 100644
--- a/devel/llvm18/Makefile
+++ b/devel/llvm18/Makefile
@@ -1,5 +1,5 @@
PORTNAME= llvm
-DISTVERSION= 18.1.3
+DISTVERSION= 18.1.4
PORTREVISION= 0
CATEGORIES= devel lang
MASTER_SITES= https://github.com/llvm/llvm-project/releases/download/llvmorg-${DISTVERSION:S/rc/-rc/}/ \
diff --git a/devel/llvm18/distinfo b/devel/llvm18/distinfo
index 1ca8cee96124..e73f95b2ea3f 100644
--- a/devel/llvm18/distinfo
+++ b/devel/llvm18/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1712248073
-SHA256 (llvm-project-18.1.3.src.tar.xz) = 2929f62d69dec0379e529eb632c40e15191e36f3bd58c2cb2df0413a0dc48651
-SIZE (llvm-project-18.1.3.src.tar.xz) = 132049300
+TIMESTAMP = 1713452670
+SHA256 (llvm-project-18.1.4.src.tar.xz) = 2c01b2fbb06819a12a92056a7fd4edcdc385837942b5e5260b9c2c0baff5116b
+SIZE (llvm-project-18.1.4.src.tar.xz) = 132054668
diff --git a/devel/llvm18/files/patch-compiler-rt_lib_sanitizer__common_sanitizer__linux__libcdep.cpp b/devel/llvm18/files/patch-compiler-rt_lib_sanitizer__common_sanitizer__linux__libcdep.cpp
new file mode 100644
index 000000000000..f62573698662
--- /dev/null
+++ b/devel/llvm18/files/patch-compiler-rt_lib_sanitizer__common_sanitizer__linux__libcdep.cpp
@@ -0,0 +1,11 @@
+--- compiler-rt/lib/sanitizer_common/sanitizer_linux_libcdep.cpp.orig
++++ compiler-rt/lib/sanitizer_common/sanitizer_linux_libcdep.cpp
+@@ -53,7 +53,7 @@
+ // that, it was never implemented. So just define it to zero.
+ # undef MAP_NORESERVE
+ # define MAP_NORESERVE 0
+-extern const Elf_Auxinfo *__elf_aux_vector;
++extern const Elf_Auxinfo *__elf_aux_vector __attribute__ ((weak));
+ # endif
+
+ # if SANITIZER_NETBSD