aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2023-02-25 14:02:13 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-02-25 14:05:18 +0000
commit1c44991d018bcb4e24cf664a236bebb7b760ddb3 (patch)
tree654596312f143a1de6407ab19242a306b21f1eaa
parent83ef1899017c7d142c4a0052348b7b606783656f (diff)
downloadports-1c44991d018bcb4e24cf664a236bebb7b760ddb3.tar.gz
ports-1c44991d018bcb4e24cf664a236bebb7b760ddb3.zip
security/clamav-lts: Remove special casing for GCC
GCC no longer serves as system compiler and we are not forcing it in any other way here. (Also, GCC 7 years ago added a -Wno-dangling-else option.) Approved by: yasu (maintainer)
-rw-r--r--security/clamav-lts/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/security/clamav-lts/Makefile b/security/clamav-lts/Makefile
index 7952c7739c41..66a3cc7e3e4c 100644
--- a/security/clamav-lts/Makefile
+++ b/security/clamav-lts/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libltdl.so:devel/libltdl \
libmspack.so:archivers/libmspack
-USES= compiler cpe gmake gnome libtool ncurses pathfix pkgconfig ssl
+USES= cpe gmake gnome libtool ncurses pathfix pkgconfig ssl
USE_LDCONFIG= yes
USE_RC_SUBR= clamav-clamd clamav-freshclam
@@ -145,13 +145,6 @@ post-patch:
${WRKSRC}/etc/clamd.conf.sample \
${WRKSRC}/etc/freshclam.conf.sample \
${WRKSRC}/etc/clamav-milter.conf.sample
-.if ${CHOSEN_COMPILER_TYPE} == gcc
- @${REINPLACE_CMD} -e 's|-Wno-logical-op-parentheses||' \
- -e 's|-Wno-dangling-else||' \
- ${WRKSRC}/libclamav/Makefile.am \
- ${WRKSRC}/libclamav/Makefile.in \
- ${WRKSRC}/libclamunrar/makefile
-.endif
pre-configure-TESTS-on:
@if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \