aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2023-07-10 21:13:34 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2023-07-10 21:15:53 +0000
commit1d3175f022639e45f7884e1950cf86ee3e17cac6 (patch)
tree6e9422f94d587ae292e3d1b521fdf04bf8caf93c
parent368e4b9267dad87af357710edfa640f0b3354203 (diff)
downloadports-1d3175f022639e45f7884e1950cf86ee3e17cac6.tar.gz
ports-1d3175f022639e45f7884e1950cf86ee3e17cac6.zip
comms/ebusd: update to 23.2
-rw-r--r--comms/ebusd/Makefile2
-rw-r--r--comms/ebusd/distinfo6
-rw-r--r--comms/ebusd/files/patch-configure.ac8
-rw-r--r--comms/ebusd/files/patch-src_ebusd_main.cpp6
-rw-r--r--comms/ebusd/files/patch-src_tools_ebusctl.cpp4
5 files changed, 13 insertions, 13 deletions
diff --git a/comms/ebusd/Makefile b/comms/ebusd/Makefile
index a96f465a8457..bb001ba1c09c 100644
--- a/comms/ebusd/Makefile
+++ b/comms/ebusd/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ebusd
-PORTVERSION= 23.1
+PORTVERSION= 23.2
CATEGORIES= comms
MAINTAINER= samm@FreeBSD.org
diff --git a/comms/ebusd/distinfo b/comms/ebusd/distinfo
index 616d92cd8ec1..efc416bc0441 100644
--- a/comms/ebusd/distinfo
+++ b/comms/ebusd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685978814
-SHA256 (john30-ebusd-23.1_GH0.tar.gz) = 179743c967cc5e0fcbe8a884d57edec2dc387d7ff6a35298d4ee0e1781be7f6f
-SIZE (john30-ebusd-23.1_GH0.tar.gz) = 563842
+TIMESTAMP = 1689021891
+SHA256 (john30-ebusd-23.2_GH0.tar.gz) = 133ec8f44c446e31cc73b1777af5045a228ee20e0024b626c5fbb947f6a31952
+SIZE (john30-ebusd-23.2_GH0.tar.gz) = 568811
diff --git a/comms/ebusd/files/patch-configure.ac b/comms/ebusd/files/patch-configure.ac
index ffea9bbbceba..4df45b0b98d6 100644
--- a/comms/ebusd/files/patch-configure.ac
+++ b/comms/ebusd/files/patch-configure.ac
@@ -1,11 +1,11 @@
---- configure.ac.orig 2022-05-08 17:50:35 UTC
+--- configure.ac.orig 2023-07-08 13:54:20 UTC
+++ configure.ac
-@@ -133,7 +133,7 @@ AM_COND_IF([CONTRIB], [AC_CONFIG_FILES([
+@@ -154,7 +154,7 @@ AM_COND_IF([KNX], [AC_CONFIG_FILES([
])])
AC_DEFINE_UNQUOTED(PACKAGE_PIDFILE, LOCALSTATEDIR "/run/" PACKAGE ".pid", [The path and name of the PID file.])
-AC_DEFINE_UNQUOTED(PACKAGE_LOGFILE, LOCALSTATEDIR "/log/" PACKAGE ".log", [The path and name of the log file.])
+AC_DEFINE_UNQUOTED(PACKAGE_LOGFILE, LOCALSTATEDIR "/log/" PACKAGE "/" PACKAGE ".log", [The path and name of the log file.])
AC_DEFINE(SCAN_VERSION, "[m4_esyscmd_s([sed -e 's#^\([0-9]*\.[0-9]*\).*#\1#' -e 's#\.\([0-9]\)$#0\1#' -e 's#\.##' VERSION])]", [The version of the package formatted for the scan result.])
- AC_DEFINE(PACKAGE_VERSION_MAJOR, "[m4_esyscmd_s([sed -e 's#^\([0-9]*\)\..*$#\1#' VERSION])]", [The major version of the package.])
- AC_DEFINE(PACKAGE_VERSION_MINOR, "[m4_esyscmd_s([sed -e 's#^.*\.\([0-9]*\)$#\1#' VERSION])]", [The minor version of the package.])
+ AC_DEFINE(PACKAGE_VERSION_MAJOR, [m4_esyscmd_s([sed -e 's#^\([0-9]*\)\..*$#\1#' VERSION])], [The major version of the package.])
+ AC_DEFINE(PACKAGE_VERSION_MINOR, [m4_esyscmd_s([sed -e 's#^.*\.\([0-9]*\)$#\1#' VERSION])], [The minor version of the package.])
diff --git a/comms/ebusd/files/patch-src_ebusd_main.cpp b/comms/ebusd/files/patch-src_ebusd_main.cpp
index c451ab1188d9..c4cf8070d4f3 100644
--- a/comms/ebusd/files/patch-src_ebusd_main.cpp
+++ b/comms/ebusd/files/patch-src_ebusd_main.cpp
@@ -1,8 +1,8 @@
---- src/ebusd/main.cpp.orig 2022-07-12 12:56:35 UTC
+--- src/ebusd/main.cpp.orig 2023-07-08 13:54:20 UTC
+++ src/ebusd/main.cpp
-@@ -34,6 +34,9 @@
- #include "lib/utils/log.h"
+@@ -36,6 +36,9 @@
#include "lib/utils/httpclient.h"
+ #include "ebusd/scan.h"
+#ifdef __FreeBSD__
+extern char **environ;
diff --git a/comms/ebusd/files/patch-src_tools_ebusctl.cpp b/comms/ebusd/files/patch-src_tools_ebusctl.cpp
index dcffdadcaf90..786c114c35fa 100644
--- a/comms/ebusd/files/patch-src_tools_ebusctl.cpp
+++ b/comms/ebusd/files/patch-src_tools_ebusctl.cpp
@@ -1,6 +1,6 @@
---- src/tools/ebusctl.cpp.orig 2022-07-12 13:01:34 UTC
+--- src/tools/ebusctl.cpp.orig 2023-07-08 13:54:20 UTC
+++ src/tools/ebusctl.cpp
-@@ -147,7 +147,13 @@ string fetchData(ebusd::TCPSocket* socket, bool &liste
+@@ -153,7 +153,13 @@ string fetchData(ebusd::TCPSocket* socket, bool &liste
time_t now;
time(&now);
time_t endTime = now + timeout;