aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Cimon <laurent@nilio.ca>2023-07-29 17:16:37 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-02 06:10:14 +0000
commit1d7aaa5de2b65ada83e7956867f1d72c6ba5c063 (patch)
treef0fbaaf55b30cce282e7d659d7be3614e69b903b
parente79188cc5ea5700509b8da86e3c89cc4966c0ec3 (diff)
downloadports-1d7aaa5de2b65ada83e7956867f1d72c6ba5c063.tar.gz
ports-1d7aaa5de2b65ada83e7956867f1d72c6ba5c063.zip
audio/ncmpc: Update to 0.48
ChangeLog: https://github.com/MusicPlayerDaemon/ncmpc/blob/master/NEWS Accumulated changes: * drop support for ~/.ncmpc/; using only ~/.config/ncmpc/ (XDG) * improve scroll-offset handling * experimental table layout * handle Ctrl-C in search prompt * link with libintl and libiconv if necessary * require libmpdclient 2.16 or newer * require MPD 0.21 or newer * switch to C++20 * eliminate Boost dependency * install Lithuanian translation * migrate to PCRE2 * make "tagtypes" errors non-fatal * check which tag types are supported by MPD (fixes MPD 0.21 support) * lyrics: update page title after loading has finished * lyrics: fix path injection bug * lyrics: load cached lyrics without plugin * lyrics: use $XDG_CACHE_HOME/ncmpc/lyrics instead of ~/.lyrics * lyrics/azlyrics: normalize accented letters (using the "unidecode" library) * lyrics/azlyrics: unescape HTML entities * fix scrolling problems on help page * highlight find results on help page * don't attempt IPv6 connection if IPv6 routing is disabled * support MPD 0.22 tags "conductor", "work", "grouping" (requires libmpdclient 2.17) * show "conductor" and "work" on song page * playlist editor (work in progress) * file page: handle mouse double clicks * fix crash bug * fix build failure on macOS * add azlyrics plugin * file page: repaint after moving cursor with mouse * file page: handle mouse click on directory * library page: mouse support * support the mouse wheel * fix assertion failure on exit PR: 272527 Reported by: laurent@nilio.ca (maintainer)
-rw-r--r--audio/ncmpc/Makefile11
-rw-r--r--audio/ncmpc/distinfo6
-rw-r--r--audio/ncmpc/files/patch-src_plugin.cxx11
-rw-r--r--audio/ncmpc/files/patch-src_screen__utils.cxx10
-rw-r--r--audio/ncmpc/files/patch-src_signals.cxx11
-rw-r--r--audio/ncmpc/pkg-plist13
6 files changed, 31 insertions, 31 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 8b553d7c8a25..204fc02b685c 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ncmpc
-PORTVERSION= 0.41
-PORTREVISION= 2
+PORTVERSION= 0.48
CATEGORIES= audio
MASTER_SITES= https://www.musicpd.org/download/ncmpc/0/
@@ -11,13 +10,13 @@ WWW= https://www.musicpd.org/clients/ncmpc/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libmpdclient.so:audio/libmpdclient \
- libpcre.so:devel/pcre
+LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
+ libpcre2-8.so:devel/pcre2
USES= compiler:c++17-lang cpe iconv localbase:ldflags meson ncurses \
- pkgconfig tar:xz
+ pkgconfig tar:xz shebangfix
MESON_ARGS= -Dlirc=disabled
+SHEBANG_GLOB= *.py
CPE_VENDOR= ncmpc_project
diff --git a/audio/ncmpc/distinfo b/audio/ncmpc/distinfo
index 51e4f8625b67..dbf2953a80de 100644
--- a/audio/ncmpc/distinfo
+++ b/audio/ncmpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602960213
-SHA256 (ncmpc-0.41.tar.xz) = 8a732a58fbec8a634625372a1c5c39f40724d6ca59320300b36ac0f15bec13ac
-SIZE (ncmpc-0.41.tar.xz) = 269280
+TIMESTAMP = 1689471482
+SHA256 (ncmpc-0.48.tar.xz) = b4b2d27e518096de2a145ef5ddf86cf46f8ba1f849bf45c6d81183a38869b90c
+SIZE (ncmpc-0.48.tar.xz) = 296320
diff --git a/audio/ncmpc/files/patch-src_plugin.cxx b/audio/ncmpc/files/patch-src_plugin.cxx
new file mode 100644
index 000000000000..dcd45c579fcc
--- /dev/null
+++ b/audio/ncmpc/files/patch-src_plugin.cxx
@@ -0,0 +1,11 @@
+--- src/plugin.cxx.orig 2023-07-16 02:01:20 UTC
++++ src/plugin.cxx
+@@ -21,6 +21,8 @@
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+
++extern char **environ;
++
+ struct PluginCycle;
+
+ class PluginPipe {
diff --git a/audio/ncmpc/files/patch-src_screen__utils.cxx b/audio/ncmpc/files/patch-src_screen__utils.cxx
deleted file mode 100644
index 3e0abd451536..000000000000
--- a/audio/ncmpc/files/patch-src_screen__utils.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/screen_utils.cxx.orig 2020-10-17 18:44:29 UTC
-+++ src/screen_utils.cxx
-@@ -31,6 +31,7 @@
- #include "WaitUserInput.hxx"
- #endif
-
-+#include <errno.h>
- #include <string.h>
-
- void
diff --git a/audio/ncmpc/files/patch-src_signals.cxx b/audio/ncmpc/files/patch-src_signals.cxx
deleted file mode 100644
index 6534b9c0f891..000000000000
--- a/audio/ncmpc/files/patch-src_signals.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/signals.cxx.orig 2020-10-17 18:45:52 UTC
-+++ src/signals.cxx
-@@ -19,6 +19,8 @@
-
- #include "Instance.hxx"
-
-+#include <signal.h>
-+
- void
- Instance::OnSigwinch() noexcept
- {
diff --git a/audio/ncmpc/pkg-plist b/audio/ncmpc/pkg-plist
index 8c93e4b546b8..d801e66459d0 100644
--- a/audio/ncmpc/pkg-plist
+++ b/audio/ncmpc/pkg-plist
@@ -1,5 +1,11 @@
bin/ncmpc
-%%LYRICS%%lib/ncmpc/lyrics/10-hd.sh
+%%LYRICS%%lib/ncmpc/lyrics/20-azlyrics.py
+%%LYRICS%%lib/ncmpc/lyrics/40-tekstowo.py
+%%LYRICS%%lib/ncmpc/lyrics/51-supermusic.py
+%%LYRICS%%lib/ncmpc/lyrics/60-google.py
+%%LYRICS%%lib/ncmpc/lyrics/30-karaoke_texty.py
+%%LYRICS%%lib/ncmpc/lyrics/50-genius.py
+%%LYRICS%%lib/ncmpc/lyrics/52-zeneszoveg.py
%%MANPAGES%%man/man1/ncmpc.1.gz
%%NLS%%share/locale/cs/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/da/LC_MESSAGES/ncmpc.mo
@@ -7,16 +13,21 @@ bin/ncmpc
%%NLS%%share/locale/en/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/eo/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/es/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/fi/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/he/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/hu/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/ie/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/it/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/ko/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/nb/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/nl/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/pl/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/sk/LC_MESSAGES/ncmpc.mo