aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-20 03:08:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-20 03:08:25 +0000
commit1dcd34af411b87cdbc585bee08d1bb31a781600f (patch)
treefb3c66b87a5ba073096f1880864a91c4a8f39e50
parentf628a6e4530ea540591ffff54b58981552eef407 (diff)
downloadports-1dcd34af411b87cdbc585bee08d1bb31a781600f.tar.gz
ports-1dcd34af411b87cdbc585bee08d1bb31a781600f.zip
science/cantera: Fix handling of Python versions
-rw-r--r--science/cantera/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/cantera/Makefile b/science/cantera/Makefile
index f31133debef8..b5d403c77058 100644
--- a/science/cantera/Makefile
+++ b/science/cantera/Makefile
@@ -45,7 +45,7 @@ OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT= PYTHON
OPTIONS_SUB= yes
-PYTHON_USES= python
+PYTHON_USES= python:3.6+
PYTHON_USE= PYTHON=cython
PYTHON_MAKE_ARGS= python_cmd="${PYTHON_CMD}"
PYTHON_MAKE_ARGS_OFF= python_package="none"
@@ -64,6 +64,6 @@ do-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcantera_shared.so.2.6.0
do-install-PYTHON-on:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cantera/_cantera.cpython-38.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cantera/_cantera.cpython-${PYTHON_VER:S/.//}.so
.include <bsd.port.mk>