aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeal Nelson <ports@nicandneal.net>2021-10-28 06:55:50 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-10-28 08:40:42 +0000
commit1de9073690687a9fb6c3b34564a71b4f2c560e9d (patch)
tree5f72cc19fc731a95233f393c1b0901d256c5c130
parentc5067c3e7ef42ebe1b7ad44cc436371e65d1d913 (diff)
downloadports-1de9073690687a9fb6c3b34564a71b4f2c560e9d.tar.gz
ports-1de9073690687a9fb6c3b34564a71b4f2c560e9d.zip
devel/py-cadquery-pywrap: Add new port
PyWrap is a C++ binding generator using pybind11, libclang and jinja. The main goal of this project is to automatically generate bindings for OCCT7.3 (opencascade) and beyond without single manual edit of the generated code. Once finished the project will be usable as a general C++ binding generator. PR: 257131
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cadquery-pywrap/Makefile39
-rw-r--r--devel/py-cadquery-pywrap/distinfo3
-rw-r--r--devel/py-cadquery-pywrap/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9f394ba50ed4..f610c96231ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4298,6 +4298,7 @@
SUBDIR += py-cachetools
SUBDIR += py-cachetools3
SUBDIR += py-cachy
+ SUBDIR += py-cadquery-pywrap
SUBDIR += py-canonicaljson
SUBDIR += py-capstone
SUBDIR += py-capturer
diff --git a/devel/py-cadquery-pywrap/Makefile b/devel/py-cadquery-pywrap/Makefile
new file mode 100644
index 000000000000..6a4daf213c67
--- /dev/null
+++ b/devel/py-cadquery-pywrap/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= cadquery-pywrap
+DISTVERSIONPREFIX= occt
+DISTVERSION= 7.5
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= C++ binding generator for python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}clang>0:devel/py-clang@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cymbal>0:devel/py-cymbal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.11.2:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}logzero>0:devel/py-logzero@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}path>0:devel/py-path@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pybind11>=2.6:devel/py-pybind11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}schema>0:devel/py-schema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>0:textproc/py-toml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toposort>0:devel/py-toposort@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR} \
+ llvm${LLVMVER}>0:devel/llvm${LLVMVER} \
+ pybind11>=2.6:devel/pybind11
+
+USES= python:3.6+
+
+USE_GITHUB= yes
+GH_ACCOUNT= CadQuery
+GH_PROJECT= pywrap
+GH_TAGNAME= e8c7bc9
+
+USE_PYTHON= autoplist concurrent distutils
+LLVMVER= 10
+
+.include <bsd.port.mk>
diff --git a/devel/py-cadquery-pywrap/distinfo b/devel/py-cadquery-pywrap/distinfo
new file mode 100644
index 000000000000..ce2afd05e92a
--- /dev/null
+++ b/devel/py-cadquery-pywrap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629989933
+SHA256 (CadQuery-pywrap-occt7.5-e8c7bc9_GH0.tar.gz) = 974f5e462213aa9be933c00d56eff4837abb65b0d0fd7f6cb014f118dc94458b
+SIZE (CadQuery-pywrap-occt7.5-e8c7bc9_GH0.tar.gz) = 5581348
diff --git a/devel/py-cadquery-pywrap/pkg-descr b/devel/py-cadquery-pywrap/pkg-descr
new file mode 100644
index 000000000000..3c585b166176
--- /dev/null
+++ b/devel/py-cadquery-pywrap/pkg-descr
@@ -0,0 +1,6 @@
+PyWrap is a C++ binding generator using pybind11, libclang and jinja.
+The main goal of this project is to automatically generate bindings for OCCT7.3
+and beyond without single manual edit of the generated code.
+Once finished the project will be usable as a general C++ binding generator.
+
+WWW: https://github.com/CadQuery/pywrap