aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-02-04 19:22:28 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-02-04 19:24:20 +0000
commit1dec0ebf85b31b0b280e449fce879919c2033e0e (patch)
treef2b9873215524135aeddaff223395b1911a85198
parent268db869e823a9dfb4cc8c31371836d07303aaec (diff)
downloadports-1dec0ebf85b31b0b280e449fce879919c2033e0e.tar.gz
ports-1dec0ebf85b31b0b280e449fce879919c2033e0e.zip
x11/zutty: Modern lightweight terminal emulator
Differential Revision: https://reviews.freebsd.org/D43551
-rw-r--r--x11/Makefile1
-rw-r--r--x11/zutty/Makefile26
-rw-r--r--x11/zutty/distinfo3
-rw-r--r--x11/zutty/pkg-descr9
4 files changed, 39 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index dd75b96ef19f..a7b9c648acaa 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -665,5 +665,6 @@
SUBDIR += yeahconsole
SUBDIR += yelp
SUBDIR += zenity
+ SUBDIR += zutty
.include <bsd.port.subdir.mk>
diff --git a/x11/zutty/Makefile b/x11/zutty/Makefile
new file mode 100644
index 000000000000..e095935d5842
--- /dev/null
+++ b/x11/zutty/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= zutty
+DISTVERSION= 0.15
+CATEGORIES= x11
+MASTER_SITES= https://git.hq.sig7.se/zutty.git/snapshot/7e481c04507e9b5cacfe67fe2b96bdb449b08726?dummy=/
+
+MAINTAINER= flo@purplekraken.com
+COMMENT= High-end terminal for low-end systems
+WWW= https://tomscii.sig7.se/zutty/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfreetype.so:print/freetype2
+
+USES= gl pkgconfig waf xorg
+USE_GL= egl glesv2
+USE_XORG= x11 xmu xt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-7e481c0
+
+PLIST_FILES= bin/zutty
+
+pre-install:
+ ${STRIP_CMD} ${WRKSRC}/build/src/zutty
+
+.include <bsd.port.mk>
diff --git a/x11/zutty/distinfo b/x11/zutty/distinfo
new file mode 100644
index 000000000000..004769b355fd
--- /dev/null
+++ b/x11/zutty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1706732320
+SHA256 (zutty-0.15.tar.gz) = 2d1ad3396de596682fcdb672cd979c254c6ce4d8fb5628705041addab979f034
+SIZE (zutty-0.15.tar.gz) = 378147
diff --git a/x11/zutty/pkg-descr b/x11/zutty/pkg-descr
new file mode 100644
index 000000000000..b42835f21b59
--- /dev/null
+++ b/x11/zutty/pkg-descr
@@ -0,0 +1,9 @@
+Zutty is a terminal emulator for the X Window System, functionally
+similar to several other X terminal emulators such as xterm, rxvt
+and countless others. It is also similar to other, much more modern,
+GPU-accelerated terminal emulators such as Alacritty and Kitty.
+What really sets Zutty apart is its radically simple, yet extremely
+efficient rendering implementation, coupled with a sufficiently
+complete feature set to make it useful for a wide range of users.
+Zutty offers high throughput with low latency, and strives to conform
+to relevant (published or de-facto) standards.