aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-30 12:39:49 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-30 13:06:45 +0000
commit1def2c041b2f3775adc325ae5e8244390c8c2767 (patch)
treec1bac75572fb4760fd45a2ce3655e82201e2ec4e
parentd187c559f003650fe5eb4b9bcdc499f623d3b4a3 (diff)
downloadports-1def2c041b2f3775adc325ae5e8244390c8c2767.tar.gz
ports-1def2c041b2f3775adc325ae5e8244390c8c2767.zip
www/py-txrequests: Mark BROKEN and DEPRECATED
- Broken since latest update with devel/py-twisted - This was a fork of www/py-requests-futures which was inactive for a while but now the development has started again. So use www/py-requests-futures instead of this. - Set EXPIRATION_DATE on 2022-12-31
-rw-r--r--www/py-txrequests/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/py-txrequests/Makefile b/www/py-txrequests/Makefile
index 1998b1e69b69..c303bac0e315 100644
--- a/www/py-txrequests/Makefile
+++ b/www/py-txrequests/Makefile
@@ -11,16 +11,20 @@ WWW= https://github.com/tardyp/txrequests
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Use www/py-requests-futures as upstream is unmaintained since 2018
+EXPIRATION_DATE= 2022-12-31
+BROKEN= Fails to build with latest devel/py-twisted
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.2.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=9.0.0:devel/py-twisted@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
-NO_ARCH= yes
-
TEST_ENV= PYTHONPATH=${TEST_WRKSRC}
+NO_ARCH= yes
+
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${LOCALBASE}/bin/trial ${WRKSRC}/test_txrequests.py