aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2023-02-03 16:35:16 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-02-04 09:09:02 +0000
commit1e149b25f57d04feeb5dc05ef33bed2f251e12bf (patch)
treeb7ec9d5bc1de5013d6f8d620d8aef7f1cd2ccf6b
parentd4663509d20d51b2aef864949afe7376ebe6462e (diff)
downloadports-1e149b25f57d04feeb5dc05ef33bed2f251e12bf.tar.gz
ports-1e149b25f57d04feeb5dc05ef33bed2f251e12bf.zip
devel/cmake-core: Fix build with libnghttp2 installed
While building the bundled curl, -I/usr/local/include appears too early on the compiler command line causing the compiler to use headers from an installed libnghttp2 instead of the bundled libnghttp2. Add USES=localbase so CFLAGS contains -isystem /usr/local/include making the compiler search the directory after all the -I flags. PR: 269253
-rw-r--r--devel/cmake-core/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/cmake-core/Makefile b/devel/cmake-core/Makefile
index 950329c71223..1c54ecdfe814 100644
--- a/devel/cmake-core/Makefile
+++ b/devel/cmake-core/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libuv.so:devel/libuv \
librhash.so:security/rhash
-USES= cmake:_internal compiler:c++11-lang cpe ncurses ssl
+USES= cmake:_internal compiler:c++11-lang cpe localbase ncurses ssl
CPE_VENDOR= cmake_project
HAS_CONFIGURE= yes