aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2023-10-01 22:15:34 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-04 19:59:56 +0000
commit1e48f38662e1eec3535a82dd6c6d1c964b937b92 (patch)
tree16cd08251fe8f452bd12195ef3646b14ba946db2
parenta4f11eab468a6e3741cb8cdced5660634917120e (diff)
downloadports-1e48f38662e1eec3535a82dd6c6d1c964b937b92.tar.gz
ports-1e48f38662e1eec3535a82dd6c6d1c964b937b92.zip
devel/py-red-black-tree-mod: New port: Flexible python implementation of red black trees
red-black-tree-mod is a pair of python modules implementing red black trees. Red-black trees are a little slower than treaps, but they give a nice low standard deviation in operation times, and this code is rather flexible. A module is provided for red black trees that enforce uniqueness. They allow for set-like use and dictionary-like use. WWW: https://stromberg.dnsalias.org/~strombrg/red-black-tree-mod PR: 274204
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-red-black-tree-mod/Makefile20
-rw-r--r--devel/py-red-black-tree-mod/distinfo3
-rw-r--r--devel/py-red-black-tree-mod/pkg-descr9
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4ddc31725530..a386c5549d8c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5497,6 +5497,7 @@
SUBDIR += py-rebulk
SUBDIR += py-recordclass
SUBDIR += py-recurring-ical-events
+ SUBDIR += py-red-black-tree-mod
SUBDIR += py-rednose
SUBDIR += py-reedsolo
SUBDIR += py-referencing
diff --git a/devel/py-red-black-tree-mod/Makefile b/devel/py-red-black-tree-mod/Makefile
new file mode 100644
index 000000000000..7d87f2aea1a5
--- /dev/null
+++ b/devel/py-red-black-tree-mod/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= red-black-tree-mod
+DISTVERSION= 1.21
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Flexible python implementation of red black trees
+WWW= https://stromberg.dnsalias.org/~strombrg/${PORTNAME} \
+ https://pypi.org/project/${PORTNAME}
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-red-black-tree-mod/distinfo b/devel/py-red-black-tree-mod/distinfo
new file mode 100644
index 000000000000..226f0aebf377
--- /dev/null
+++ b/devel/py-red-black-tree-mod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696185588
+SHA256 (red-black-tree-mod-1.21.tar.gz) = f4e06ac7942db836e93dc4db45f1e8302c5ff98a797e8d14565d971f262ef25c
+SIZE (red-black-tree-mod-1.21.tar.gz) = 32735
diff --git a/devel/py-red-black-tree-mod/pkg-descr b/devel/py-red-black-tree-mod/pkg-descr
new file mode 100644
index 000000000000..cb0c2a249046
--- /dev/null
+++ b/devel/py-red-black-tree-mod/pkg-descr
@@ -0,0 +1,9 @@
+red-black-tree-mod is a pair of python modules implementing red
+black trees.
+
+Red-black trees are a little slower than treaps, but they give a
+nice low standard deviation in operation times, and this code is
+rather flexible.
+
+A module is provided for red black trees that enforce uniqueness.
+They allow for set-like use and dictionary-like use.