aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 06:51:56 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 06:51:56 +0000
commit1e823de58e838e9ab734c84c545a11ceceb47258 (patch)
tree235613f2ed2cdca03857daa07aae196255362eb2
parente89872ec76c3191693ed439c46d85b50a47b2738 (diff)
downloadports-1e823de58e838e9ab734c84c545a11ceceb47258.tar.gz
ports-1e823de58e838e9ab734c84c545a11ceceb47258.zip
devel/cvise: Remove CC/CPP/CXX exports
USES=llvm now by default exports CC/CPP/CXX so remove those
-rw-r--r--devel/cvise/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/devel/cvise/Makefile b/devel/cvise/Makefile
index 492c4e32904f..61355b46f56b 100644
--- a/devel/cvise/Makefile
+++ b/devel/cvise/Makefile
@@ -36,18 +36,10 @@ SHEBANG_FILES= cvise-delta.py cvise.py
CMAKE_ARGS+= -DLLVM_DIR:PATH=${LLVM_PREFIX}/lib/cmake/llvm
CMAKE_ARGS+= -DClang_DIR:PATH=${LLVM_PREFIX}/lib/cmake/clang
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} < 150
-CPP= clang-cpp${LLVM_VERSION}
-CC= clang${LLVM_VERSION}
-CXX= clang++${LLVM_VERSION}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/cvise.py
do-test:
cd ${BUILD_WRKSRC} && pytest
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>