aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-18 07:56:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-18 08:17:14 +0000
commit1f18b49a254e6969f37f8bdd72bbcd50d0434a8b (patch)
treeb9ba52293d29e3e9bf67b891c41e9eacc77303eb
parentda5dac98a0155f3933d1c54d9e0f9f5b1f5b5121 (diff)
downloadports-1f18b49a254e6969f37f8bdd72bbcd50d0434a8b.tar.gz
ports-1f18b49a254e6969f37f8bdd72bbcd50d0434a8b.zip
devel/lefthook: New port: Fast and powerful Git hooks manager for any type of projects
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lefthook/Makefile19
-rw-r--r--devel/lefthook/distinfo5
-rw-r--r--devel/lefthook/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7518ca0b7b97..d72eb230e350 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1080,6 +1080,7 @@
SUBDIR += lcov
SUBDIR += leaktracer
SUBDIR += leatherman
+ SUBDIR += lefthook
SUBDIR += leiningen
SUBDIR += lemon
SUBDIR += level-zero
diff --git a/devel/lefthook/Makefile b/devel/lefthook/Makefile
new file mode 100644
index 000000000000..adf7a014d288
--- /dev/null
+++ b/devel/lefthook/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= lefthook
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.3
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast and powerful Git hooks manager for any type of projects
+WWW= https://github.com/evilmartians/lefthook
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/evilmartians/lefthook
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/lefthook/distinfo b/devel/lefthook/distinfo
new file mode 100644
index 000000000000..f28c16a91a79
--- /dev/null
+++ b/devel/lefthook/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1666079292
+SHA256 (go/devel_lefthook/lefthook-v1.1.3/v1.1.3.mod) = e2e63c3c0da2f38175e0d091982730932e5e73122786bde34f8596190460a0d6
+SIZE (go/devel_lefthook/lefthook-v1.1.3/v1.1.3.mod) = 1403
+SHA256 (go/devel_lefthook/lefthook-v1.1.3/v1.1.3.zip) = 9af1df1d49155a58309ffe2d889f2ef9ae2b61d6f5ec1b3ef4edcb5a1e06a6e4
+SIZE (go/devel_lefthook/lefthook-v1.1.3/v1.1.3.zip) = 100605
diff --git a/devel/lefthook/pkg-descr b/devel/lefthook/pkg-descr
new file mode 100644
index 000000000000..c68287df8f2a
--- /dev/null
+++ b/devel/lefthook/pkg-descr
@@ -0,0 +1,8 @@
+lefthook is a fast and powerful Git hooks manager for Node.js, Ruby or any other
+type of projects.
+
+Features:
+* Fast. It is written in Go. Can run commands in parallel.
+* Powerful. With a few lines in the config you can check only the changed files
+ on pre-push hook.
+* Simple. It is single dependency-free binary which can work in any environment.