aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 21:25:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 21:34:41 +0000
commit1fbc349286764d7aaf0282e7221492f45ac8c590 (patch)
tree9aecaf0c4b852d8adfff4c3e558b9d3822106c3e
parentcfa2121d4b8a548b27c9b4f0d766547a17d9a8a9 (diff)
downloadports-1fbc349286764d7aaf0282e7221492f45ac8c590.tar.gz
ports-1fbc349286764d7aaf0282e7221492f45ac8c590.zip
www/py-aioquic: Update to 0.9.21
- Convert to USE_PYTHON=pep517 Changes: https://github.com/aiortc/aioquic/commits/main
-rw-r--r--www/py-aioquic/Makefile9
-rw-r--r--www/py-aioquic/distinfo6
-rw-r--r--www/py-aioquic/files/patch-pyproject.toml11
3 files changed, 19 insertions, 7 deletions
diff --git a/www/py-aioquic/Makefile b/www/py-aioquic/Makefile
index 5a9e67023d16..f98f362bcae6 100644
--- a/www/py-aioquic/Makefile
+++ b/www/py-aioquic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= aioquic
-PORTVERSION= 0.9.20
+PORTVERSION= 0.9.21
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,13 +11,14 @@ WWW= https://github.com/aiortc/aioquic
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=3.1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pylsqpack>=0.3.3<0.4.0:www/py-pylsqpack@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=20:security/py-openssl@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}openssl>=21,1:security/py-openssl@${PY_FLAVOR}
USES= python ssl
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
diff --git a/www/py-aioquic/distinfo b/www/py-aioquic/distinfo
index 406323d24838..439868e8c4b1 100644
--- a/www/py-aioquic/distinfo
+++ b/www/py-aioquic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649423846
-SHA256 (aioquic-0.9.20.tar.gz) = ec436aaace997b846b01e5200edbf7e3e56b91826a144efb9748fd8ddd332bbe
-SIZE (aioquic-0.9.20.tar.gz) = 153457
+TIMESTAMP = 1688902189
+SHA256 (aioquic-0.9.21.tar.gz) = 79c7ec06318e785627665ca4e8723adf347b7225b7d006e332d2575a1f516ef5
+SIZE (aioquic-0.9.21.tar.gz) = 153384
diff --git a/www/py-aioquic/files/patch-pyproject.toml b/www/py-aioquic/files/patch-pyproject.toml
new file mode 100644
index 000000000000..f7b900d9b7e1
--- /dev/null
+++ b/www/py-aioquic/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2023-07-04 09:19:50 UTC
++++ pyproject.toml
+@@ -29,7 +29,7 @@ classifiers = [
+ dependencies = [
+ "certifi",
+ "pylsqpack>=0.3.3,<0.4.0",
+- "pyopenssl>=22",
++ "pyopenssl>=21",
+ ]
+ dynamic = ["version"]
+