aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2024-06-19 07:39:37 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2024-06-19 13:20:53 +0000
commit2007b26000f49fb040d855ccf03edbdf7d641014 (patch)
treea388522f7dbdd99f5aa5b5b4f9c91d1286228557
parent3e65a40aa3956ed33c408886715dc5de55f8931e (diff)
downloadports-2007b26000f49fb040d855ccf03edbdf7d641014.tar.gz
ports-2007b26000f49fb040d855ccf03edbdf7d641014.zip
graphics/mesa: Remove Makefile.targets
This was only used to specify directory for drirc.d but the default one works fine. No functional changes intended. Sponsored by: Beckhoff Automation GmbH & Co. KG
-rw-r--r--graphics/libosmesa/Makefile2
-rw-r--r--graphics/mesa-dri/Makefile2
-rw-r--r--graphics/mesa-dri/Makefile.targets6
-rw-r--r--graphics/mesa-gallium-va/Makefile1
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile1
-rw-r--r--graphics/mesa-gallium-xa/Makefile1
-rw-r--r--graphics/mesa-libs/Makefile2
-rw-r--r--lang/clover/Makefile2
8 files changed, 0 insertions, 17 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 17a3660608b2..12cdb2ef0e38 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -44,8 +44,6 @@ LDFLAGS_i386= -Wl,-znotext
MESON_ARGS+= -Dosmesa=true
-.include "${MASTERDIR}/Makefile.targets"
-
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/GL
${INSTALL_DATA} ${WRKSRC}/include/GL/osmesa.h \
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index fb837f0ae8fb..f9ba777266c4 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -106,8 +106,6 @@ PLIST_SUB+= ${_vd}_VDRIVER="@comment "
. endif
.endfor
-.include "${MASTERDIR}/Makefile.targets"
-
post-install:
@${RM} -r ${STAGEDIR}/etc/OpenCL
${INSTALL_DATA} ${FILESDIR}/01-freebsd.conf \
diff --git a/graphics/mesa-dri/Makefile.targets b/graphics/mesa-dri/Makefile.targets
deleted file mode 100644
index b7e891579ab7..000000000000
--- a/graphics/mesa-dri/Makefile.targets
+++ /dev/null
@@ -1,6 +0,0 @@
-# this file holds common targets
-
-post-patch:
- ${REINPLACE_CMD} -e '/SYSCONFDIR/ s|/etc|${PREFIX}/etc|g' \
- -e '/DATADIR/ s|/usr/share|${PREFIX}/share|g' \
- ${WRKSRC}/src/util/xmlconfig.c
diff --git a/graphics/mesa-gallium-va/Makefile b/graphics/mesa-gallium-va/Makefile
index ebf93902640f..d9cca9b9cc55 100644
--- a/graphics/mesa-gallium-va/Makefile
+++ b/graphics/mesa-gallium-va/Makefile
@@ -59,5 +59,4 @@ MESON_ARGS+= -Dglx=disabled \
-Dplatforms=""
.endif
-.include "${MASTERDIR}/Makefile.targets"
.include <bsd.port.post.mk>
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
index f541b25211cf..43727c18f358 100644
--- a/graphics/mesa-gallium-vdpau/Makefile
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -57,5 +57,4 @@ MESON_ARGS+= -Dglx=disabled \
-Dplatforms=""
.endif
-.include "${MASTERDIR}/Makefile.targets"
.include <bsd.port.post.mk>
diff --git a/graphics/mesa-gallium-xa/Makefile b/graphics/mesa-gallium-xa/Makefile
index 72d13b41fa26..60c582ff6270 100644
--- a/graphics/mesa-gallium-xa/Makefile
+++ b/graphics/mesa-gallium-xa/Makefile
@@ -43,5 +43,4 @@ LDFLAGS_i386= -Wl,-znotext
MESON_ARGS+= -Dgallium-xa=enabled
-.include "${MASTERDIR}/Makefile.targets"
.include <bsd.port.post.mk>
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index 6f235b58b015..f0bb8f7ec8e7 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -75,8 +75,6 @@ MESON_ARGS+= -Dplatforms="${MESA_PLATFORMS:ts,:tl}"
LDFLAGS+=-Wl,-z,notext
.endif
-.include "${MASTERDIR}/Makefile.targets"
-
post-install:
# Fallback if GLX_EXT_libglvnd is missing or vendor library doesn't exist
@${ECHO_CMD} "libGLX_indirect.so.0 libGLX_mesa.so.0" \
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index cb318016c189..580b8b1f41a1 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -52,8 +52,6 @@ LDFLAGS_i386= -Wl,-znotext
CONFIGURE_ENV+= PKG_CONFIG_PATH="${LLVM_PREFIX}/libdata/pkgconfig"
-.include "${MASTERDIR}/Makefile.targets"
-
pre-patch:
@if [ -e ${LOCALBASE}/bin/llvm-config${LLVM_VERSION} ] && \
! [ -e ${LOCALBASE}/bin/clang${LLVM_VERSION} ]; then \