aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2022-07-22 10:24:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2022-07-22 13:52:23 +0000
commit2086e377dc8b0eea4bc34e8a5340cae5485808a2 (patch)
tree13b665f036b192d35491ba1e976371c5a3e3bf64
parent34f95b934d089c23e1ae98ea363ee6eb42f862ad (diff)
downloadports-2086e377dc8b0eea4bc34e8a5340cae5485808a2.tar.gz
ports-2086e377dc8b0eea4bc34e8a5340cae5485808a2.zip
dns/bind916: update to 9.16.31
Changes: https://downloads.isc.org/isc/bind9/9.16.31/doc/arm/html/notes.html#notes-for-bind-9-16-31 MFH: 2022Q3 (cherry picked from commit 0bd2969d042c09d6782fa2ed109f3eb2ec094c78)
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
3 files changed, 10 insertions, 10 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index dcefa8762ce9..ffd84ee5e114 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.30
+ISCVERSION= 9.16.31
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index fa8517a0aeb5..aac5766b38af 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655372228
-SHA256 (bind-9.16.30.tar.xz) = 009fc3f013a787ae57b545ad6afab40fd27b99d24f823142ac67e28baf1260db
-SIZE (bind-9.16.30.tar.xz) = 5086288
+TIMESTAMP = 1658484522
+SHA256 (bind-9.16.31.tar.xz) = 8ca2cb6c37b605c70f7a25f0cf8a94d2040e025824db2341b92625efd96e7cfb
+SIZE (bind-9.16.31.tar.xz) = 5087424
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 7ccf9d5444e7..a16b3b16378c 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2022-04-11 15:28:12 UTC
+--- bin/named/config.c.orig 2022-07-11 04:55:00 UTC
+++ bin/named/config.c
@@ -176,6 +176,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2022-04-11 15:28:12 UTC
+--- bin/named/server.c.orig 2022-07-11 04:55:00 UTC
+++ bin/named/server.c
@@ -4424,6 +4424,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2022-04-11 15:28:12 UTC
+--- lib/dns/include/dns/view.h.orig 2022-07-11 04:55:00 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2022-04-11 15:28:12 UTC
+--- lib/dns/resolver.c.orig 2022-07-11 04:55:00 UTC
+++ lib/dns/resolver.c
-@@ -6486,6 +6486,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6420,6 +6420,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2022-04-11 15:28:12 UTC
+--- lib/isccfg/namedconf.c.orig 2022-07-11 04:55:00 UTC
+++ lib/isccfg/namedconf.c
@@ -2051,6 +2051,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */