aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-12 16:34:52 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-12 16:56:22 +0000
commit2096f8f0c0e7614e633900f3a6a141bdbd60da07 (patch)
treeb5bdd543e40a08166c610bef435417a44ebd59a2
parent2f7e0897ab8533e63d079cb9c10204973316b965 (diff)
downloadports-2096f8f0c0e7614e633900f3a6a141bdbd60da07.tar.gz
ports-2096f8f0c0e7614e633900f3a6a141bdbd60da07.zip
devel/git-cinnabar: unbreak after 65831666797c
patch -p1 -F0 -o helper/csum-file.patched.c git-core/csum-file.c < helper/csum-file.c.patch Hmm... Looks like a unified diff to me... The text leading up to this was: -------------------------- |diff --git a/csum-file.c b/csum-file.c |index 7510950fa3..19d02e3a63 100644 |--- a/csum-file.c |+++ b/csum-file.c -------------------------- Patching file git-core/csum-file.c using Plan A... Hunk #1 failed at 86. 1 out of 1 hunks failed--saving rejects to helper/csum-file.patched.c.rej done gmake[2]: *** [helper/helper.mk:99: helper/csum-file.patched.c] Error 1
-rw-r--r--devel/git-cinnabar/Makefile2
-rw-r--r--devel/git-cinnabar/files/patch-git-2.3327
2 files changed, 28 insertions, 1 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index 156569027afe..e0c94286ab9f 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -1,6 +1,6 @@
PORTNAME= git-cinnabar
DISTVERSION= 0.5.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
diff --git a/devel/git-cinnabar/files/patch-git-2.33 b/devel/git-cinnabar/files/patch-git-2.33
new file mode 100644
index 000000000000..469b600e802c
--- /dev/null
+++ b/devel/git-cinnabar/files/patch-git-2.33
@@ -0,0 +1,27 @@
+https://github.com/glandium/git-cinnabar/commit/ea33ee10ac39
+
+--- helper/GIT-VERSION.mk.orig 2021-03-31 21:58:42 UTC
++++ helper/GIT-VERSION.mk
+@@ -1,2 +1,2 @@
+-GIT_VERSION ?= v2.32.0
++GIT_VERSION ?= v2.33.0
+ WINDOWS_GIT_VERSION ?= $(GIT_VERSION).windows.1
+--- helper/csum-file.c.patch.orig 2021-03-31 21:58:42 UTC
++++ helper/csum-file.c.patch
+@@ -1,8 +1,8 @@
+ diff --git a/csum-file.c b/csum-file.c
+-index 7510950fa3..19d02e3a63 100644
++index c951cf8277..1215459b01 100644
+ --- a/csum-file.c
+ +++ b/csum-file.c
+-@@ -86,7 +86,7 @@ int finalize_hashfile(struct hashfile *f, unsigned char *result, unsigned int fl
++@@ -91,7 +91,7 @@ int finalize_hashfile(struct hashfile *f, unsigned char *result, unsigned int fl
+ return fd;
+ }
+
+@@ -10,4 +10,4 @@ index 7510950fa3..19d02e3a63 100644
+ +void real_hashwrite(struct hashfile *f, const void *buf, unsigned int count)
+ {
+ while (count) {
+- unsigned left = sizeof(f->buffer) - f->offset;
++ unsigned left = f->buffer_len - f->offset;