aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-24 20:30:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-24 20:32:12 +0000
commit20fd52ed177b90bd7b6510f097c2b59b377ca0db (patch)
tree3b88085a259b43b421c18dbb1165b3dafee306af
parent7ff45dc2f4731461bb91d9284cf9ed55f2a0d8e1 (diff)
downloadports-20fd52ed177b90bd7b6510f097c2b59b377ca0db.tar.gz
ports-20fd52ed177b90bd7b6510f097c2b59b377ca0db.zip
Mk/Uses/php.mk: Fix USES
- Avoid overriding or appending USES. - Use USESDIR instead of PORTSDIR/Mk/Uses Reported by: antoine
-rw-r--r--Mk/Uses/php.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index c87eb96c4ad8..39d91019af7b 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -273,8 +273,8 @@ BUILD_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. endif
RUN_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. if ${php_ARGS:Mmod} || (${php_ARGS:Mweb} && defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == "")
-USES= apache:run
-.include "${PORTSDIR}/Mk/Uses/apache.mk"
+apache_ARGS?=run
+.include "${USESDIR}/apache.mk"
RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp.so:${MOD_PHP_PORT}
. endif