aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-23 02:42:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-23 02:56:45 +0000
commit210e12463231af19cec8008dc2043a9db4338ea9 (patch)
treeacf34282ec8e3695205689d3170a8761d0c0ff4f
parent362ade45f8500addacff204e1e10b9eea2d24e6a (diff)
downloadports-210e12463231af19cec8008dc2043a9db4338ea9.tar.gz
ports-210e12463231af19cec8008dc2043a9db4338ea9.zip
archivers/py-laszip: New port: Bindings for LASzip made with pybind11
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-laszip/Makefile28
-rw-r--r--archivers/py-laszip/distinfo3
-rw-r--r--archivers/py-laszip/files/patch-pyproject.toml11
-rw-r--r--archivers/py-laszip/pkg-descr3
5 files changed, 46 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index aa9aa1032174..934ec6a3fe58 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -192,6 +192,7 @@
SUBDIR += py-bz2file
SUBDIR += py-compressed-rtf
SUBDIR += py-cramjam
+ SUBDIR += py-laszip
SUBDIR += py-libarchive-c
SUBDIR += py-lz4
SUBDIR += py-lzma
diff --git a/archivers/py-laszip/Makefile b/archivers/py-laszip/Makefile
new file mode 100644
index 000000000000..1e8c8677da72
--- /dev/null
+++ b/archivers/py-laszip/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= laszip
+DISTVERSION= 0.2.3
+CATEGORIES= archivers
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Bindings for LASzip made with pybind11
+WWW= https://laspy.readthedocs.io/en/latest/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/License.txt
+
+BUILD_DEPENDS= cmake:devel/cmake-core \
+ ninja:devel/ninja \
+ ${PYTHON_PKGNAMEPREFIX}pybind11>=2.10:devel/py-pybind11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyproject-metadata>=0.7.1:devel/py-pyproject-metadata@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-build-core>=0.1.5:devel/py-scikit-build-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+LIB_DEPENDS= liblaszip.so:archivers/laszip
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= tmontaigu
+GH_PROJECT= laszip-python
+
+.include <bsd.port.mk>
diff --git a/archivers/py-laszip/distinfo b/archivers/py-laszip/distinfo
new file mode 100644
index 000000000000..8f061f32d859
--- /dev/null
+++ b/archivers/py-laszip/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1698026487
+SHA256 (tmontaigu-laszip-python-0.2.3_GH0.tar.gz) = 31572639a928fabf7d60a340970c6ae256ae9382e0420e938d6ab237553ac57b
+SIZE (tmontaigu-laszip-python-0.2.3_GH0.tar.gz) = 11256
diff --git a/archivers/py-laszip/files/patch-pyproject.toml b/archivers/py-laszip/files/patch-pyproject.toml
new file mode 100644
index 000000000000..6067d1332a33
--- /dev/null
+++ b/archivers/py-laszip/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2023-10-23 02:32:14 UTC
++++ pyproject.toml
+@@ -1,8 +1,6 @@
+ [build-system]
+ requires = [
+ "scikit-build-core>=0.1.5",
+- "cmake>=3.20",
+- "ninja",
+ "pybind11>=2.10",
+ ]
+ build-backend = "scikit_build_core.build"
diff --git a/archivers/py-laszip/pkg-descr b/archivers/py-laszip/pkg-descr
new file mode 100644
index 000000000000..9acda66665a6
--- /dev/null
+++ b/archivers/py-laszip/pkg-descr
@@ -0,0 +1,3 @@
+laszip is a Python bindings for LASzip.
+
+The main purpose is for integration within laspy.