aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-01-11 06:38:09 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-01-11 06:39:19 +0000
commit210ea0c13c6c5049444f5bf8b5271f53d979c01e (patch)
tree6ce562450e8206f44c11733994e4322d3705dcea
parentd9d4201a6cd71827e3c572b49f34f5142ca90539 (diff)
downloadports-210ea0c13c6c5049444f5bf8b5271f53d979c01e.tar.gz
ports-210ea0c13c6c5049444f5bf8b5271f53d979c01e.zip
www/ungoogled-chromium: update to 120.0.6099.216
include a better arm64 cpu feature detection patch from jbeich@ while here Security: https://vuxml.freebsd.org/freebsd/ec8e4040-afcd-11ee-86bb-a8a1599412c6.html (cherry picked from commit ddbf184ea4a9d208bbba44462d8805bea5fd62a9)
-rw-r--r--www/ungoogled-chromium/Makefile2
-rw-r--r--www/ungoogled-chromium/distinfo14
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c35
3 files changed, 29 insertions, 22 deletions
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index e5556bb2021e..d2768fa95a72 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ungoogled-chromium
-PORTVERSION= 120.0.6099.199
+PORTVERSION= 120.0.6099.216
UGVERSION= ${DISTVERSION}-1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
diff --git a/www/ungoogled-chromium/distinfo b/www/ungoogled-chromium/distinfo
index 347d75900d4a..0c5a2ab383e5 100644
--- a/www/ungoogled-chromium/distinfo
+++ b/www/ungoogled-chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1704569501
-SHA256 (chromium-120.0.6099.199.tar.xz) = 84009db5c898517f38f7b44b81b8a98e21fd28ca3f9aad9dda07516d8640574c
-SIZE (chromium-120.0.6099.199.tar.xz) = 3285099132
-SHA256 (ungoogled-chromium-120.0.6099.199-1.tar.gz) = 33cf5428b87e9046172a714ab119ddc750eb83f3ef72f3d6187d38671c02f91a
-SIZE (ungoogled-chromium-120.0.6099.199-1.tar.gz) = 665906
-SHA256 (chromium-120.0.6099.199-testdata.tar.xz) = 089b154017795238f529108edb7cead30fb68bfaa3b976625128060554950ff9
-SIZE (chromium-120.0.6099.199-testdata.tar.xz) = 271532952
+TIMESTAMP = 1704955013
+SHA256 (chromium-120.0.6099.216.tar.xz) = 7e7bea15bf56f3cc920bb015fed1a1b1368267299e132e795935c5cc604adfc0
+SIZE (chromium-120.0.6099.216.tar.xz) = 3296304596
+SHA256 (ungoogled-chromium-120.0.6099.216-1.tar.gz) = 131b6fec2bca4435b2542d46df716af79a62bf80fc00c48898de640dd852aa8e
+SIZE (ungoogled-chromium-120.0.6099.216-1.tar.gz) = 665895
+SHA256 (chromium-120.0.6099.216-testdata.tar.xz) = c66136fa24d77fb27c04fca4fd2fec15004efad68f551d156eab038de93f40c6
+SIZE (chromium-120.0.6099.216-testdata.tar.xz) = 271802184
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/ungoogled-chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c b/www/ungoogled-chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
index 92163a805c0c..ceeec71c950d 100644
--- a/www/ungoogled-chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
+++ b/www/ungoogled-chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
@@ -1,20 +1,27 @@
---- third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c.orig 2024-01-08 12:52:53 UTC
+--- third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c.orig 2024-01-09 18:29:07 UTC
+++ third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c
-@@ -153,7 +153,16 @@ static int arm_get_cpu_caps(void) {
+@@ -91,9 +91,23 @@ static int arm_get_cpu_caps(void) {
return flags;
}
--#else // end __Fuchsia__
-+#elif defined(__FreeBSD__) // end __Fuchsia__
+-#elif defined(__linux__) // end defined(VPX_USE_ANDROID_CPU_FEATURES)
++#elif defined(__linux__) || defined(__FreeBSD__) // end defined(VPX_USE_ANDROID_CPU_FEATURES)
+
+ #include <sys/auxv.h>
++
++#if defined(__FreeBSD__)
++static unsigned long getauxval(unsigned long type)
++{
++ /* Only AT_HWCAP* return unsigned long */
++ if (type != AT_HWCAP && type != AT_HWCAP2) {
++ return 0;
++ }
+
-+int arm_get_cpu_caps(void) {
-+ int flags = 0;
-+#if HAVE_NEON
-+ flags |= HAS_NEON; // Neon is mandatory in Armv8.0-A.
-+#endif // HAVE_NEON
-+ return flags;
++ unsigned long ret = 0;
++ elf_aux_info(type, &ret, sizeof(ret));
++ return ret;
+}
-+#else // end __FreeBSD__
- #error \
- "Runtime CPU detection selected, but no CPU detection method available" \
- "for your platform. Rerun configure with --disable-runtime-cpu-detect."
++#endif
+
+ // Define hwcap values ourselves: building with an old auxv header where these
+ // hwcap values are not defined should not prevent features from being enabled.