aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2023-09-01 02:51:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2023-09-01 02:54:14 +0000
commit2153f48f70e02118c3fc7b7f0ab4f5468869e6df (patch)
tree80b8e74e6bc62b1504d1322f4e2ae49bd81384fd
parentc7af9c73998dfa653e03a3f3e002fb88e9252339 (diff)
downloadports-2153f48f70e02118c3fc7b7f0ab4f5468869e6df.tar.gz
ports-2153f48f70e02118c3fc7b7f0ab4f5468869e6df.zip
sysutils/bmd-plugin-avahi: add new ports.
PR: 273436 Reported by: Yuichiro NAITO <naito.yuichiro at gmail.com>
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bmd-plugin-avahi/Makefile25
-rw-r--r--sysutils/bmd-plugin-avahi/distinfo3
-rw-r--r--sysutils/bmd-plugin-avahi/files/patch-Makefile12
-rw-r--r--sysutils/bmd-plugin-avahi/pkg-descr5
-rw-r--r--sysutils/bmd-plugin-avahi/pkg-plist3
6 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6444f5258e49..e1e7eeccc70e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -137,6 +137,7 @@
SUBDIR += bkt
SUBDIR += blisp
SUBDIR += bmd
+ SUBDIR += bmd-plugin-avahi
SUBDIR += boot-extract
SUBDIR += bottom
SUBDIR += bpytop
diff --git a/sysutils/bmd-plugin-avahi/Makefile b/sysutils/bmd-plugin-avahi/Makefile
new file mode 100644
index 000000000000..284d98ccb6fb
--- /dev/null
+++ b/sysutils/bmd-plugin-avahi/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= bmd-plugin-avahi
+DISTVERSION= 1.0
+CATEGORIES= sysutils
+
+MAINTAINER= naito.yuichiro@gmail.com
+COMMENT= BMD plugin avahi
+WWW= https://github.com/yuichiro-naito/bmd-plugin-avahi
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# Because bhyve runs on amd64 only.
+ONLY_FOR_ARCHS= amd64
+
+BUILD_DEPENDS= bmd>0:sysutils/bmd
+RUN_DEPENDS= bmd>0:sysutils/bmd \
+ avahi-app>0:net/avahi-app
+
+USE_GITHUB= yes
+GH_ACCOUNT= yuichiro-naito
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}/${LOCALBASE}/libexec/bmd
+
+.include <bsd.port.mk>
diff --git a/sysutils/bmd-plugin-avahi/distinfo b/sysutils/bmd-plugin-avahi/distinfo
new file mode 100644
index 000000000000..e803cdf0383b
--- /dev/null
+++ b/sysutils/bmd-plugin-avahi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692698325
+SHA256 (yuichiro-naito-bmd-plugin-avahi-1.0_GH0.tar.gz) = 88b0e2c3dcd1d11f6a8e16ce609e8fc2c2d0d18fb2bc2c9aa5c4be194e35f0f2
+SIZE (yuichiro-naito-bmd-plugin-avahi-1.0_GH0.tar.gz) = 2818
diff --git a/sysutils/bmd-plugin-avahi/files/patch-Makefile b/sysutils/bmd-plugin-avahi/files/patch-Makefile
new file mode 100644
index 000000000000..eae16e94d2e3
--- /dev/null
+++ b/sysutils/bmd-plugin-avahi/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2023-08-15 08:44:56 UTC
++++ Makefile
+@@ -1,5 +1,9 @@ MK_DEBUG_FILES= no
+ LOCALBASE?= /usr/local
+ MK_DEBUG_FILES= no
++BINOWN!= id -u
++BINGRP!= id -g
++SHAREOWN= ${BINOWN}
++SHAREGRP= ${BINGRP}
+ SHLIB= bmdplugin_avahi
+ SHLIB_MAJOR= 1
+ CFLAGS+= -I${LOCALBASE}/include -DLOCALBASE=\"${LOCALBASE}\"
diff --git a/sysutils/bmd-plugin-avahi/pkg-descr b/sysutils/bmd-plugin-avahi/pkg-descr
new file mode 100644
index 000000000000..424f0d3d1326
--- /dev/null
+++ b/sysutils/bmd-plugin-avahi/pkg-descr
@@ -0,0 +1,5 @@
+The bmd-plugin-avahi publishes VM's vnc port using `avahi-publish` command.
+Clients can lookup the vnc port by mDNS protocol. If you use MacOS,
+open Finder and Network placement folder then you can find the VM name. And
+click it to connect to the remove vnc display. Gtk client `bvnc` is also
+available in 'avahi-gtk3' package.
diff --git a/sysutils/bmd-plugin-avahi/pkg-plist b/sysutils/bmd-plugin-avahi/pkg-plist
new file mode 100644
index 000000000000..598fddb2b2da
--- /dev/null
+++ b/sysutils/bmd-plugin-avahi/pkg-plist
@@ -0,0 +1,3 @@
+libexec/bmd/libbmdplugin_avahi.so
+libexec/bmd/libbmdplugin_avahi.so.1
+man/man8/bmd-plugin-avahi.8.gz