aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:30:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:30:14 +0000
commit21f0fcb9c3139539083f5e5a5bfc74b4e170ab81 (patch)
tree672bb833fd7c3246f6d344b0274dd9d4ba6e77fe
parent658dc4df06f0846fb46e7ebad45e347085761eab (diff)
downloadports-21f0fcb9c3139539083f5e5a5bfc74b4e170ab81.tar.gz
ports-21f0fcb9c3139539083f5e5a5bfc74b4e170ab81.zip
security/py-webauthn: Update to 1.11.0
-rw-r--r--security/py-webauthn/Makefile11
-rw-r--r--security/py-webauthn/distinfo6
-rw-r--r--security/py-webauthn/files/patch-setup.py11
3 files changed, 19 insertions, 9 deletions
diff --git a/security/py-webauthn/Makefile b/security/py-webauthn/Makefile
index 5c03442dcf41..78bae00b8e7a 100644
--- a/security/py-webauthn/Makefile
+++ b/security/py-webauthn/Makefile
@@ -1,5 +1,5 @@
PORTNAME= webauthn
-PORTVERSION= 1.2.1
+PORTVERSION= 1.11.0
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,10 @@ WWW= https://github.com/duo-labs/py_webauthn
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=0.24.0:devel/py-asn1crypto@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}attrs>=21.2.0:devel/py-attrs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cattrs>=1.8.0:devel/py-cattrs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cbor2>=4.0.1:devel/py-cbor2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=20.0.1,1:security/py-openssl@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.4.0:devel/py-asn1crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cbor2>=5.4.2.post1:devel/py-cbor2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydantic>=1.10.11:devel/py-pydantic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=23.2.0,1:security/py-openssl@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent cryptography distutils unittest
diff --git a/security/py-webauthn/distinfo b/security/py-webauthn/distinfo
index 8b79f0a17d51..c8521e80fa41 100644
--- a/security/py-webauthn/distinfo
+++ b/security/py-webauthn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1652122695
-SHA256 (webauthn-1.2.1.tar.gz) = 3a9565e4587d6322a2c69c92faa89f40e211893f41b5993a410cdef7bc43d06b
-SIZE (webauthn-1.2.1.tar.gz) = 43506
+TIMESTAMP = 1696048448
+SHA256 (webauthn-1.11.0.tar.gz) = 1e808de1e3625a4b361e249e1bbb254d2a3a5c6b206e6f7260c4febe51f45276
+SIZE (webauthn-1.11.0.tar.gz) = 48747
diff --git a/security/py-webauthn/files/patch-setup.py b/security/py-webauthn/files/patch-setup.py
new file mode 100644
index 000000000000..99f515f37882
--- /dev/null
+++ b/security/py-webauthn/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-09-29 21:11:21 UTC
++++ setup.py
+@@ -49,7 +49,7 @@ setup(
+ ],
+ install_requires=[
+ 'asn1crypto>=1.4.0',
+- 'cbor2>=5.4.6',
++ 'cbor2>=5.4.2.post1',
+ 'cryptography>=41.0.4',
+ 'pydantic>=1.10.11',
+ 'pyOpenSSL>=23.2.0',