aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-21 19:40:05 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-21 19:40:05 +0000
commit2200a356e4b7e83058a1fb48d01326bfe8772909 (patch)
treefb07ce21ad358eabad99e1bcc0334dfa68e9c604
parenteefcfdabff91435353e0fb63cc554405b4ca9c4f (diff)
downloadports-2200a356e4b7e83058a1fb48d01326bfe8772909.tar.gz
ports-2200a356e4b7e83058a1fb48d01326bfe8772909.zip
lang/gcc12-devel: disable LTO on armv6/7
PR: 261977 Requested by: fuz@fuz.su
-rw-r--r--lang/gcc12-devel/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/lang/gcc12-devel/Makefile b/lang/gcc12-devel/Makefile
index 11ff23a9e40e..f814e2948aee 100644
--- a/lang/gcc12-devel/Makefile
+++ b/lang/gcc12-devel/Makefile
@@ -42,9 +42,17 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
CFLAGS:= ${CFLAGS:N-mretpoline}
CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-OPTIONS_DEFINE= BOOTSTRAP GRAPHITE
-OPTIONS_DEFAULT= BOOTSTRAP
-BOOTSTRAP_DESC= Build using a full bootstrap
+OPTIONS_DEFINE= GRAPHITE
+OPTIONS_DEFAULT_aarch64=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_amd64= LTO_BOOTSTRAP
+OPTIONS_DEFAULT_i386= LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc64=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc64le=LTO_BOOTSTRAP
+OPTIONS_RADIO= BOOTSTRAP
+OPTIONS_RADIO_BOOTSTRAP= LTO_BOOTSTRAP STANDARD_BOOTSTRAP
+LTO_BOOTSTRAP_DESC= Build using a full LTO bootstrap
+STANDARD_BOOTSTRAP_DESC= Build using a full bootstrap without LTO
GRAPHITE_DESC= Support for Graphite loop optimizations
.if exists(/usr/lib32/libc.so)
@@ -80,11 +88,14 @@ TARGLIB32= ${PREFIX}/lib32 # The version information is added later
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
-.if empty(PORT_OPTIONS:MBOOTSTRAP)
+.if empty(PORT_OPTIONS:M*BOOTSTRAP)
CONFIGURE_ARGS+=--disable-bootstrap
-.else
+.elif ${PORT_OPTIONS:MLTO_BOOTSTRAP}
CONFIGURE_ARGS+=--with-build-config=bootstrap-lto-noplugin
ALL_TARGET= bootstrap-lean
+.else
+CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
+ALL_TARGET= bootstrap-lean
.endif
INSTALL_TARGET= install-strip
.if ${UID} != 0