aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-21 08:31:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-21 08:32:09 +0000
commit227a7ec58e072e722cf20e23173e1fcb7a504a8a (patch)
treee74410613c8f60c4db55bdac190b85d76bfb8048
parentc48d8c2fadd0859608274d869384ad2f7a0ac973 (diff)
downloadports-227a7ec58e072e722cf20e23173e1fcb7a504a8a.tar.gz
ports-227a7ec58e072e722cf20e23173e1fcb7a504a8a.zip
science/py-rmf: Update 1.1 -> 1.2
Reported by: portscout
-rw-r--r--science/py-rmf/Makefile20
-rw-r--r--science/py-rmf/distinfo6
-rw-r--r--science/py-rmf/files/patch-CMakeLists.txt25
-rw-r--r--science/py-rmf/files/patch-include_CMakeLists.txt7
-rw-r--r--science/py-rmf/files/patch-swig_CMakeLists.txt10
5 files changed, 39 insertions, 29 deletions
diff --git a/science/py-rmf/Makefile b/science/py-rmf/Makefile
index e2f1b67b87f8..f9ca624e40a3 100644
--- a/science/py-rmf/Makefile
+++ b/science/py-rmf/Makefile
@@ -1,6 +1,5 @@
PORTNAME= rmf
-DISTVERSION= 1.1
-PORTREVISION= 1
+DISTVERSION= 1.2
CATEGORIES= science graphics
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,14 +13,25 @@ BUILD_DEPENDS= swig:devel/swig
LIB_DEPENDS= libRMF.so:science/rmf
USES= cmake compiler:c++11-lang python:3.6+ shebangfix
+USE_PYTHON= flavors
+
USE_GITHUB= yes
GH_ACCOUNT= salilab
-GH_TAGNAME= f917cf2
+
SHEBANG_GLOB= *.py
-USE_PYTHON= flavors
CMAKE_ARGS= -DCMAKE_INSTALL_PYTHONDIR:STRING=${PYTHON_SITELIBDIR}
-BINARY_ALIAS= python=${PYTHON_CMD}
+
LDFLAGS+= -lRMF
+BINARY_ALIAS= python=${PYTHON_CMD}
+
+do-test:
+ @${RM} ${WRKSRC}/test/*.cpp
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DFREEBSD_BUILS_WITH_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+
.include <bsd.port.mk>
diff --git a/science/py-rmf/distinfo b/science/py-rmf/distinfo
index d0fc154f5d1b..cc0bafb334c0 100644
--- a/science/py-rmf/distinfo
+++ b/science/py-rmf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535650392
-SHA256 (salilab-rmf-1.1-f917cf2_GH0.tar.gz) = 9c877539b8c7a6af38b3d7155522a90b16b3e28596ec27ac941c7f812f1a1c6f
-SIZE (salilab-rmf-1.1-f917cf2_GH0.tar.gz) = 15087905
+TIMESTAMP = 1618992396
+SHA256 (salilab-rmf-1.2_GH0.tar.gz) = 72ee7c8083f1c1f089fda239b4e94297252149aafefdd71736ede04e00267420
+SIZE (salilab-rmf-1.2_GH0.tar.gz) = 15090975
diff --git a/science/py-rmf/files/patch-CMakeLists.txt b/science/py-rmf/files/patch-CMakeLists.txt
index 77ab9ec45a9d..75845b666b0d 100644
--- a/science/py-rmf/files/patch-CMakeLists.txt
+++ b/science/py-rmf/files/patch-CMakeLists.txt
@@ -1,10 +1,10 @@
---- CMakeLists.txt.orig 2018-06-15 00:56:51 UTC
+--- CMakeLists.txt.orig 2021-04-19 19:25:22 UTC
+++ CMakeLists.txt
-@@ -4,15 +4,15 @@ project(RMF)
- # needs to be in main CMakeLists.txt
- enable_testing()
+@@ -18,15 +18,15 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_S
+ include(cmake_modules/IMPFindPython.cmake)
+ imp_find_python()
--execute_process(COMMAND python setup_git.py
+-execute_process(COMMAND ${PYTHON_EXECUTABLE} setup_git.py
- RESULT_VARIABLE setup
- OUTPUT_VARIABLE toutput
- ERROR_VARIABLE error
@@ -13,7 +13,7 @@
-if(NOT ${setup} EQUAL 0)
- message(FATAL_ERROR " Failed to run setup_git.py: ${setup}; ${error}")
-endif()
-+#execute_process(COMMAND python setup_git.py
++#execute_process(COMMAND ${PYTHON_EXECUTABLE} setup_git.py
+# RESULT_VARIABLE setup
+# OUTPUT_VARIABLE toutput
+# ERROR_VARIABLE error
@@ -23,9 +23,9 @@
+# message(FATAL_ERROR " Failed to run setup_git.py: ${setup}; ${error}")
+#endif()
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/cmake_modules)
-
-@@ -116,14 +116,14 @@ configure_file (
+ # Don't deref quoted variables in if()
+ if(POLICY CMP0054)
+@@ -144,14 +144,14 @@ configure_file (
"${PROJECT_BINARY_DIR}/include/RMF/config.h"
)
@@ -45,15 +45,16 @@
# swig support is a little broken
-@@ -142,10 +142,10 @@ endif()
+@@ -170,10 +170,12 @@ endif()
add_subdirectory(swig)
--add_subdirectory(test)
++if (FREEBSD_BUILS_WITH_TESTS)
+ add_subdirectory(test)
-add_subdirectory(examples)
-add_subdirectory(benchmark)
-add_subdirectory(doc)
-+#add_subdirectory(test)
++endif()
+#add_subdirectory(examples)
+#add_subdirectory(benchmark)
+#add_subdirectory(doc)
diff --git a/science/py-rmf/files/patch-include_CMakeLists.txt b/science/py-rmf/files/patch-include_CMakeLists.txt
index 8570c72f3abf..a42adc4c050f 100644
--- a/science/py-rmf/files/patch-include_CMakeLists.txt
+++ b/science/py-rmf/files/patch-include_CMakeLists.txt
@@ -1,10 +1,9 @@
---- include/CMakeLists.txt.orig 2018-06-30 22:26:02 UTC
+--- include/CMakeLists.txt.orig 2021-04-19 19:25:22 UTC
+++ include/CMakeLists.txt
-@@ -16,5 +16,5 @@ add_custom_target(RMF-decorators ALL DEP
+@@ -16,6 +16,3 @@ add_custom_target(RMF-decorators ALL DEPENDS "${PROJEC
"${PROJECT_SOURCE_DIR}/tools/build/make_decorators.py")
set_property(TARGET "RMF-decorators" PROPERTY FOLDER "RMF")
-INSTALL(DIRECTORY ${PROJECT_SOURCE_DIR}/include/RMF DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+-INSTALL(FILES ${PROJECT_BINARY_DIR}/include/RMF.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/include/RMF DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-+#INSTALL(DIRECTORY ${PROJECT_SOURCE_DIR}/include/RMF DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-+#INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/include/RMF DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
diff --git a/science/py-rmf/files/patch-swig_CMakeLists.txt b/science/py-rmf/files/patch-swig_CMakeLists.txt
index 2deb3fa057a3..6a815d654e70 100644
--- a/science/py-rmf/files/patch-swig_CMakeLists.txt
+++ b/science/py-rmf/files/patch-swig_CMakeLists.txt
@@ -1,6 +1,6 @@
---- swig/CMakeLists.txt.orig 2018-06-15 00:56:51 UTC
+--- swig/CMakeLists.txt.orig 2021-04-19 19:25:22 UTC
+++ swig/CMakeLists.txt
-@@ -59,7 +59,7 @@ set_target_properties("${SWIG_MODULE_RMF
+@@ -43,7 +43,7 @@ set_target_properties("${SWIG_MODULE_RMF_REAL_NAME}" P
IF(WIN32)
SWIG_LINK_LIBRARIES(RMF ${PYTHON_LIBRARIES} RMF-lib)
ELSE(WIN32)
@@ -9,7 +9,7 @@
ENDIF(WIN32)
INSTALL(TARGETS ${SWIG_MODULE_RMF_REAL_NAME} DESTINATION ${CMAKE_INSTALL_PYTHONDIR})
-@@ -95,7 +95,7 @@ set_target_properties("${SWIG_MODULE_RMF
+@@ -79,7 +79,7 @@ set_target_properties("${SWIG_MODULE_RMF_HDF5_REAL_NAM
set(RMF_SWIG _RMF CACHE INTERNAL "" FORCE)
@@ -18,7 +18,7 @@
# Don't link in libpython (that prevents the extension from being used in
-@@ -104,7 +104,7 @@ INSTALL(FILES "RMF.i" ${SWIG_INCLUDES} D
+@@ -88,7 +88,7 @@ INSTALL(FILES "RMF.i" ${SWIG_INCLUDES} DESTINATION "${
IF(WIN32)
SWIG_LINK_LIBRARIES(RMF_HDF5 ${PYTHON_LIBRARIES} RMF-lib)
ELSE(WIN32)
@@ -27,7 +27,7 @@
ENDIF(WIN32)
# Apple linkers complain by default if there are undefined symbols
IF(APPLE)
-@@ -116,6 +116,6 @@ INSTALL(TARGETS ${SWIG_MODULE_RMF_HDF5_R
+@@ -100,6 +100,6 @@ INSTALL(TARGETS ${SWIG_MODULE_RMF_HDF5_REAL_NAME} DEST
INSTALL(FILES "${CMAKE_BINARY_DIR}/lib/RMF_HDF5.py" DESTINATION ${CMAKE_INSTALL_PYTHONDIR})
set(RMF_SWIG _RMF _RMF_HDF5 CACHE INTERNAL "" FORCE)