aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-08 13:05:44 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-04-12 15:23:04 +0000
commit229ce36802676a474c0906dd485ca459e556075d (patch)
tree86df7f7885dff4a219bb63ef67ee28a9c7c5891d
parent2f8328651233b3c95b59b952fadf6b09b9ca3618 (diff)
downloadports-229ce36802676a474c0906dd485ca459e556075d.tar.gz
ports-229ce36802676a474c0906dd485ca459e556075d.zip
sysutils/cpu-x@ncurses: unbreak the port's packaging under Poudriere
Back in 2020 diizzy@ had reported that daemon was installed in the wrong path when the port was built under Poudriere without X11 (GTK+) support. This seemed totally odd (and not reproducible in the Tinderbox) so I've scratched my head and put it off for better times. When the port was converted to flavors, the problem had resurfaced: now the ncurses flavor was failing on the cluster! Looking at the CMake code, it calls `include(GNUInstallDirs)' which correctly sets CMAKE_INSTALL_FULL_LIBEXECDIR to `/usr/local/libexec'. The code then checks for its existence, the failure logs indicate that it does not exist, which should not be possible because it is part of the `Templates/BSD.local.dist', so it should be mtree'd inside the build jail. Tinderbox does exactly this, but not Poudriere, so unless this directory is created (populated) by the dependencies or e.g. ccache(1), one cannot assume that it really exists in pristine environment. Regardless of whether mtree'ing jail with `BSD.local.dist' is the right thing or not, checking for some common path existence and setting it to something else if it's not found is definitely wrong. This was a joint investigation by fluffy@ and yours truly. PR: 251785 (cherry picked from commit eb6c9c8c4aa5981078c6b9b69527ecdaee5f22c9)
-rw-r--r--sysutils/cpu-x/files/patch-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/cpu-x/files/patch-CMakeLists.txt b/sysutils/cpu-x/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..61c772ba735f
--- /dev/null
+++ b/sysutils/cpu-x/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2023-04-02 10:14:25 UTC
++++ CMakeLists.txt
+@@ -14,10 +14,6 @@ project(cpu-x
+ # Global variables
+ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+ include(GNUInstallDirs)
+-if(NOT EXISTS ${CMAKE_INSTALL_FULL_LIBEXECDIR})
+- set(CMAKE_INSTALL_LIBEXECDIR lib/${CMAKE_PROJECT_NAME})
+- set(CMAKE_INSTALL_FULL_LIBEXECDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR})
+-endif(NOT EXISTS ${CMAKE_INSTALL_FULL_LIBEXECDIR})
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/output/bin/)
+ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/output/lib/)
+ set(CMAKE_DATA_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/output/data/)