aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-06-20 18:52:55 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-06-21 18:25:37 +0000
commit22c4f7a75ed3de4b97368be49f1ab70ab0aabb27 (patch)
treef0eb0378b156dfcec2442b59fe20e2a86f51c16b
parent7fdd67ec48e7780a922ce6043f04294ab10d5ae7 (diff)
downloadports-22c4f7a75ed3de4b97368be49f1ab70ab0aabb27.tar.gz
ports-22c4f7a75ed3de4b97368be49f1ab70ab0aabb27.zip
math/cbc: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because math/cbc's build infrastructure does not explicitly set its C++ standard, this leads to errors: ./CbcSymmetry.hpp:83:30: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] inline void color_vertex(register int k) { color = k; } ^~~~~~~~~ ./CbcSymmetry.hpp:91:24: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] inline void bounds(register double a, register double b) ^~~~~~~~~ To work around the error, add USE_CXXSTD=gnu++11 to compile for C++11 with GNU extensions instead. PR: 272101 Approved by: yuri (maintainer) MFH: 2023Q2
-rw-r--r--math/cbc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/cbc/Makefile b/math/cbc/Makefile
index 491bc4f00bd2..484909ff9cf6 100644
--- a/math/cbc/Makefile
+++ b/math/cbc/Makefile
@@ -1,7 +1,7 @@
PORTNAME= cbc
DISTVERSIONPREFIX= releases/
DISTVERSION= 2.10.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
PKGNAMEPREFIX= coin-or-
@@ -25,6 +25,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libOsi.so:math/osi
USES= compiler:c++11-lang fortran gmake libtool localbase pkgconfig
+USE_CXXSTD= gnu++11
USE_LDCONFIG= yes
USE_GITHUB= yes