aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2023-11-15 08:15:56 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2023-11-16 08:10:05 +0000
commit22e0a974790709a32f73c1f1d9c4f6666fa39cc4 (patch)
treea1f427f4b1baf188bb68c1740c91c1cc30484543
parentc991821fdb850a9e40d346eea117d41a9d9c3c26 (diff)
downloadports-22e0a974790709a32f73c1f1d9c4f6666fa39cc4.tar.gz
ports-22e0a974790709a32f73c1f1d9c4f6666fa39cc4.zip
security/py-omemo-dr: New port
Python library initially forked from python-axolotl, heavily rewritten, focusing only on OMEMO cryptographic sessions, and not on communication protocols. PR: 271876 Co-Authored-By: Alastair Hogge <agh@riseup.net>
-rw-r--r--security/Makefile1
-rw-r--r--security/py-omemo-dr/Makefile23
-rw-r--r--security/py-omemo-dr/distinfo3
-rw-r--r--security/py-omemo-dr/files/patch-pyproject.toml9
-rw-r--r--security/py-omemo-dr/pkg-descr2
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5f1ee9e1b0b8..a196dc27e927 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -960,6 +960,7 @@
SUBDIR += py-ntlm-auth
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
+ SUBDIR += py-omemo-dr
SUBDIR += py-onlykey
SUBDIR += py-openssl
SUBDIR += py-oscrypto
diff --git a/security/py-omemo-dr/Makefile b/security/py-omemo-dr/Makefile
new file mode 100644
index 000000000000..e9aefb1dbbe2
--- /dev/null
+++ b/security/py-omemo-dr/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= omemo-dr
+DISTVERSION= 1.0.1
+CATEGORIES= security python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= agh@riseup.net
+COMMENT= OMEMO Crypto Library
+WWW= https://dev.gajim.org/gajim/omemo-dr
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}build>0:devel/py-build@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.0:devel/py-protobuf@${PY_FLAVOR}
+
+USES= python:3.9+
+USE_PYTHON= autoplist pep517
+
+.include <bsd.port.mk>
diff --git a/security/py-omemo-dr/distinfo b/security/py-omemo-dr/distinfo
new file mode 100644
index 000000000000..22df08a1a0fc
--- /dev/null
+++ b/security/py-omemo-dr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1700035755
+SHA256 (omemo-dr-1.0.1.tar.gz) = 2a8a8c77231d73949bdd375278d4d5a261252bdaee52cb6241acb251c202d361
+SIZE (omemo-dr-1.0.1.tar.gz) = 152526
diff --git a/security/py-omemo-dr/files/patch-pyproject.toml b/security/py-omemo-dr/files/patch-pyproject.toml
new file mode 100644
index 000000000000..4132840f60be
--- /dev/null
+++ b/security/py-omemo-dr/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2023-10-09 00:03:25 UTC
++++ pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools>=65.0.0"]
++requires = ["setuptools>=63.0.0"]
+ build-backend = "setuptools.build_meta"
+
+ [project]
diff --git a/security/py-omemo-dr/pkg-descr b/security/py-omemo-dr/pkg-descr
new file mode 100644
index 000000000000..c242a4baf8ee
--- /dev/null
+++ b/security/py-omemo-dr/pkg-descr
@@ -0,0 +1,2 @@
+Python library initially forked from python-axolotl, heavily rewritten, focusing
+only on OMEMO cryptographic sessions, and not on communication protocols.