aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-01 19:23:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-01 23:43:13 +0000
commit22f4628894c4b6309afe3b86e76046193a96ee4b (patch)
treeb00d1e9544f143ebff4ddfc8939f335e82a9d4ce
parenta0a2255e0b5c9f36160d49db0af9f7608384c2ce (diff)
downloadports-22f4628894c4b6309afe3b86e76046193a96ee4b.tar.gz
ports-22f4628894c4b6309afe3b86e76046193a96ee4b.zip
finance/py-pytrends: New port: Pseudo API for Google Trends
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-pytrends/Makefile25
-rw-r--r--finance/py-pytrends/distinfo3
-rw-r--r--finance/py-pytrends/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index bd2b7c359d8c..d89d8eda439d 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -124,6 +124,7 @@
SUBDIR += py-python-binance
SUBDIR += py-python-bitcoinlib
SUBDIR += py-python-obelisk
+ SUBDIR += py-pytrends
SUBDIR += py-quantecon
SUBDIR += py-stocksera
SUBDIR += py-stripe
diff --git a/finance/py-pytrends/Makefile b/finance/py-pytrends/Makefile
new file mode 100644
index 000000000000..4e3b80ed2dd2
--- /dev/null
+++ b/finance/py-pytrends/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pytrends
+DISTVERSION= 4.9.2
+CATEGORIES= finance python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pseudo API for Google Trends
+WWW= https://github.com/GeneralMills/pytrends
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.25:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # many tests fail, see https://github.com/GeneralMills/pytrends/issues/608
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-pytrends/distinfo b/finance/py-pytrends/distinfo
new file mode 100644
index 000000000000..ee1da1825be7
--- /dev/null
+++ b/finance/py-pytrends/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1704136383
+SHA256 (pytrends-4.9.2.tar.gz) = 691c6e36b1aeaa4754f3692bdbad0dff446e528ffb052eee2e7f139aaa2c6989
+SIZE (pytrends-4.9.2.tar.gz) = 247162
diff --git a/finance/py-pytrends/pkg-descr b/finance/py-pytrends/pkg-descr
new file mode 100644
index 000000000000..5909adadf4fb
--- /dev/null
+++ b/finance/py-pytrends/pkg-descr
@@ -0,0 +1,4 @@
+pytrends is an unofficial API for Google Trends.
+
+It allows simple interface for automating downloading of reports from Google
+Trends.