aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:47:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:16 +0000
commit232e5967dc8d7f4c0cae9acba16942e2b5460208 (patch)
treeee3f7240cbd3aa0ed7e069c3cefdea95bb4a4fc2
parenta8becea1602b9bfec5118c49a5e88e5b7a1550b8 (diff)
downloadports-232e5967dc8d7f4c0cae9acba16942e2b5460208.tar.gz
ports-232e5967dc8d7f4c0cae9acba16942e2b5460208.zip
science/py-geometer: Revert f92330acaec14f33e17c3161b7f843c8010d72b2 and allow build with newer py-numpy in another way
- Remove upper bound of py-numpy for now - Bump PORTREVISION for package change We should remove all PYNUMPY and use the real version requirement.
-rw-r--r--science/py-geometer/Makefile4
-rw-r--r--science/py-geometer/files/patch-setup.py2
2 files changed, 3 insertions, 3 deletions
diff --git a/science/py-geometer/Makefile b/science/py-geometer/Makefile
index 52ccc3398f0a..cac16b710836 100644
--- a/science/py-geometer/Makefile
+++ b/science/py-geometer/Makefile
@@ -1,6 +1,6 @@
PORTNAME= geometer
PORTVERSION= 0.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ WWW= https://github.com/jan-mue/geometer
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.15,1:math/py-numpy@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
diff --git a/science/py-geometer/files/patch-setup.py b/science/py-geometer/files/patch-setup.py
index 1f084c317f18..103ff70c23f5 100644
--- a/science/py-geometer/files/patch-setup.py
+++ b/science/py-geometer/files/patch-setup.py
@@ -5,7 +5,7 @@
# What packages are required for this module to be executed?
-REQUIRED = ["numpy>=1.15,<1.23"]
-+REQUIRED = ["numpy>=1.15,<1.24"]
++REQUIRED = ["numpy>=1.15"]
# What packages are optional?
EXTRAS = {