aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-03 00:20:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-03 01:29:50 +0000
commit23b2ba41c2cd4322f24c44e63af3925efeb248d7 (patch)
tree1559e07ec2404f179dd08ec0c908f26bcb9df369
parent084f9f78443ef3ef618907059dfab095b669d6cd (diff)
downloadports-23b2ba41c2cd4322f24c44e63af3925efeb248d7.tar.gz
ports-23b2ba41c2cd4322f24c44e63af3925efeb248d7.zip
www/lagrange: Unbreak with OpenSSL 3.0.0 and later
- Update version 1.7.3=>1.15.9 Changelog: https://github.com/skyjake/lagrange/releases/tag/v1.15.9 Approved by: portmgr (blanket)
-rw-r--r--www/lagrange/Makefile13
-rw-r--r--www/lagrange/distinfo6
-rw-r--r--www/lagrange/files/patch-cmake_Depends.cmake (renamed from www/lagrange/files/patch-Depends.cmake)6
-rw-r--r--www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake8
-rw-r--r--www/lagrange/files/patch-lib_the__Foundation_Depends.cmake26
-rw-r--r--www/lagrange/pkg-plist1
6 files changed, 35 insertions, 25 deletions
diff --git a/www/lagrange/Makefile b/www/lagrange/Makefile
index 20402916f4e1..a79deeaff76c 100644
--- a/www/lagrange/Makefile
+++ b/www/lagrange/Makefile
@@ -1,6 +1,5 @@
PORTNAME= lagrange
-DISTVERSION= 1.7.3
-PORTREVISION= 1
+DISTVERSION= 1.15.9
CATEGORIES= www
MASTER_SITES= https://git.skyjake.fi/gemini/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -14,20 +13,22 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
BROKEN_SSL= libressl
BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL
+BUILD_DEPENDS= zip>0:archivers/zip
LIB_DEPENDS= libfribidi.so:converters/fribidi \
libharfbuzz.so:print/harfbuzz \
libmpg123.so:audio/mpg123 \
- libpcre.so:devel/pcre \
+ libpcre2-8.so:devel/pcre2 \
libunistring.so:devel/libunistring
-USES= cmake compiler:c11 desktop-file-utils pkgconfig sdl ssl
+USES= cmake compiler:c11 desktop-file-utils pkgconfig sdl ssl xorg
USE_SDL= sdl2
+USE_XORG= x11 xext
+
+LDFLAGS+= -lssl -lcrypto
OPTIONS_DEFINE= SSE41
SSE41_DESC= Enable SSE4.1 support
SSE41_CMAKE_ON= -DTFDN_ENABLE_SSE41:BOOL=ON
-OPENSSL_LDFLAGS= -lssl -lcrypto
-
.include <bsd.port.mk>
diff --git a/www/lagrange/distinfo b/www/lagrange/distinfo
index b59d929a0043..1626ab93e0bd 100644
--- a/www/lagrange/distinfo
+++ b/www/lagrange/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635979811
-SHA256 (lagrange-1.7.3.tar.gz) = 46d9ad305aca2cbe0ef52060a28634c9ed20098e1784e7e9f787ae5d0394ef9d
-SIZE (lagrange-1.7.3.tar.gz) = 22816390
+TIMESTAMP = 1683054333
+SHA256 (lagrange-1.15.9.tar.gz) = 43cb380c19fc51a2b7fda80e49956f1782b5012b6f271d0c3fd24f4dad2df6a6
+SIZE (lagrange-1.15.9.tar.gz) = 9987069
diff --git a/www/lagrange/files/patch-Depends.cmake b/www/lagrange/files/patch-cmake_Depends.cmake
index 4a12c1bc6db3..70c6aebf1c9d 100644
--- a/www/lagrange/files/patch-Depends.cmake
+++ b/www/lagrange/files/patch-cmake_Depends.cmake
@@ -1,6 +1,6 @@
---- Depends.cmake.orig 2021-09-09 10:00:30 UTC
-+++ Depends.cmake
-@@ -138,6 +138,7 @@ else ()
+--- cmake/Depends.cmake.orig 2023-05-02 20:13:29 UTC
++++ cmake/Depends.cmake
+@@ -42,6 +42,7 @@ else ()
set (TFDN_ENABLE_WEBREQUEST OFF CACHE BOOL "")
add_subdirectory (lib/the_Foundation)
add_library (the_Foundation::the_Foundation ALIAS the_Foundation)
diff --git a/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake b/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake
index 20c25373b943..2cac873b549c 100644
--- a/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake
+++ b/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake
@@ -5,10 +5,14 @@ feature-set, this becomes a problem when a build
hosts support it, whilst package consumers do not,
causing an instant crash upon startup.
---- lib/the_Foundation/CheckSSE.cmake.orig 2021-04-22 10:39:48 UTC
+--- lib/the_Foundation/CheckSSE.cmake.orig 2023-05-02 19:35:44 UTC
+++ lib/the_Foundation/CheckSSE.cmake
-@@ -1,22 +1 @@
+@@ -1,26 +1 @@
set (SSE41_FOUND NO)
+-if (DEFINED TFDN_ENABLE_SSE41 AND NOT TFDN_ENABLE_SSE41)
+- return ()
+-endif ()
+-
-try_run (
- sseRunCode
- sseCompiled
diff --git a/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake b/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake
index 10c50eb016de..0c374da92768 100644
--- a/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake
+++ b/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake
@@ -1,13 +1,17 @@
---- lib/the_Foundation/Depends.cmake.orig 2021-11-03 22:54:49 UTC
+--- lib/the_Foundation/Depends.cmake.orig 2023-05-02 20:08:20 UTC
+++ lib/the_Foundation/Depends.cmake
-@@ -10,9 +10,8 @@ if (NOT IOS)
- set (iHaveCurl NO)
- endif ()
- if (TFDN_ENABLE_TLSREQUEST)
-- pkg_check_modules (OPENSSL eopenssl11) # BSD
- if (NOT OPENSSL_FOUND)
-- pkg_check_modules (OPENSSL openssl)
-+ find_package (OpenSSL REQUIRED)
+@@ -24,13 +24,12 @@ if (NOT IOS AND NOT ANDROID)
+ target_link_libraries (libssl INTERFACE ${LIBSSL} ${LIBCRYPTO})
+ set (OPENSSL_FOUND YES)
+ else ()
+- pkg_check_modules (OPENSSL eopenssl11)
+ if (OPENSSL_FOUND)
+ set (EOPENSSL_FOUND YES)
+ endif ()
+ endif ()
+ else ()
+- pkg_check_modules (OPENSSL openssl)
++ find_package (OpenSSL REQUIRED)
endif ()
- else ()
- set (OPENSSL_FOUND NO)
+ endif ()
+ # Unicode text strings
diff --git a/www/lagrange/pkg-plist b/www/lagrange/pkg-plist
index 6ac19a7b9d30..993da280f218 100644
--- a/www/lagrange/pkg-plist
+++ b/www/lagrange/pkg-plist
@@ -2,4 +2,5 @@ bin/lagrange
%%DATADIR%%/resources.lgr
share/applications/fi.skyjake.Lagrange.desktop
share/icons/hicolor/256x256/apps/fi.skyjake.Lagrange.png
+share/man/man1/lagrange.1.gz
share/metainfo/fi.skyjake.Lagrange.appdata.xml