aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-18 17:56:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-18 18:00:44 +0000
commit23e962ce40708aeb7b04ad5ee34d78053d640d82 (patch)
tree3997dca0bd7da17a820488f9e34ba907f7aaa2f4
parentbd2ca73c62ee926e425cc515c540793626281584 (diff)
downloadports-23e962ce40708aeb7b04ad5ee34d78053d640d82.tar.gz
ports-23e962ce40708aeb7b04ad5ee34d78053d640d82.zip
net/py-pyroute2: Update to 0.7.1
-rw-r--r--net/py-pyroute2/Makefile12
-rw-r--r--net/py-pyroute2/distinfo6
-rw-r--r--net/py-pyroute2/files/patch-setup.cfg12
-rw-r--r--net/py-pyroute2/files/setup.py3
4 files changed, 10 insertions, 23 deletions
diff --git a/net/py-pyroute2/Makefile b/net/py-pyroute2/Makefile
index 15ef435c48c8..9dc3492bd056 100644
--- a/net/py-pyroute2/Makefile
+++ b/net/py-pyroute2/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= pyroute2
-PORTVERSION= 0.6.13
+PORTVERSION= 0.7.1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,13 +14,6 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.Apache.v2
LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.GPL.v2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyroute2.core>=0:net/py-pyroute2.core@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyroute2.ethtool>=0:net/py-pyroute2.ethtool@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyroute2.ipset>=0:net/py-pyroute2.ipset@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyroute2.ndb>=0:net/py-pyroute2.ndb@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyroute2.nftables>=0:net/py-pyroute2.nftables@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyroute2.nslink>=0:net/py-pyroute2.nslink@${PY_FLAVOR}
-
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
@@ -37,4 +30,7 @@ SS2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=5.0<6:sysutils/py-psutil@${PY_FL
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
+post-patch:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
+
.include <bsd.port.post.mk>
diff --git a/net/py-pyroute2/distinfo b/net/py-pyroute2/distinfo
index c38bdbbb0913..efe015312f0e 100644
--- a/net/py-pyroute2/distinfo
+++ b/net/py-pyroute2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656092948
-SHA256 (pyroute2-0.6.13.tar.gz) = b03d49a581945fec2b1ec7d1d5125c6f40ba04ed11affc90c4caddc019e25792
-SIZE (pyroute2-0.6.13.tar.gz) = 24412
+TIMESTAMP = 1658151379
+SHA256 (pyroute2-0.7.1.tar.gz) = a72b5aacdafe9416f8ac9aa3ed5d6f27c6968288d82568432e0f703a1753dd96
+SIZE (pyroute2-0.7.1.tar.gz) = 398752
diff --git a/net/py-pyroute2/files/patch-setup.cfg b/net/py-pyroute2/files/patch-setup.cfg
deleted file mode 100644
index a05594b5f0b8..000000000000
--- a/net/py-pyroute2/files/patch-setup.cfg
+++ /dev/null
@@ -1,12 +0,0 @@
-Reference: https://github.com/svinota/pyroute2/discussions/788
-
---- setup.cfg.orig 2022-06-23 21:11:52 UTC
-+++ setup.cfg
-@@ -37,7 +37,6 @@ install_requires =
- pyroute2.nftables
- pyroute2.ethtool
- pyroute2.ipset
-- pyroute2.ipdb
- pyroute2.ndb
- packages_dir =
- =pyroute2
diff --git a/net/py-pyroute2/files/setup.py b/net/py-pyroute2/files/setup.py
new file mode 100644
index 000000000000..606849326a40
--- /dev/null
+++ b/net/py-pyroute2/files/setup.py
@@ -0,0 +1,3 @@
+from setuptools import setup
+
+setup()