aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-27 04:44:03 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-27 04:47:45 +0000
commit23f90f6ac1782493aa23ef94180421825b3ca1e9 (patch)
tree0494661db685853f0d1523f5faa59cfdc271308d
parenta6dbff875fc327a352562c5397b1c1d8fc79822a (diff)
downloadports-23f90f6ac1782493aa23ef94180421825b3ca1e9.tar.gz
ports-23f90f6ac1782493aa23ef94180421825b3ca1e9.zip
comms/xastir: Remove BDB5 support
Remove support for deprecated BDB 5 PR: 279126 Reviewed by: Carl Makin <carl@stagecraft.cx> (maintainer)
-rw-r--r--comms/xastir/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 5a763c0fa359..56e271568161 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -1,7 +1,7 @@
PORTNAME= xastir
DISTVERSIONPREFIX= Release-
DISTVERSION= 2.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= comms hamradio
MAINTAINER= carl@stagecraft.cx
@@ -43,7 +43,9 @@ GH_PROJECT= Xastir
SUB_FILES= pkg-message
-OPTIONS_DEFINE= BDB CURL DAVIS ERRORPOP FESTIVAL GEOTIFF GPSMAN
+CONFIGURE_ARGS= --without-map-cache
+
+OPTIONS_DEFINE= CURL DAVIS ERRORPOP FESTIVAL GEOTIFF GPSMAN
OPTIONS_RADIO= MGG
OPTIONS_RADIO_MGG= GMAGICK IMAGICK
@@ -53,12 +55,11 @@ GEOTIFF_DESC= Include GeoTIFF Support
GPSMAN_DESC= Include GPSMAN Support
FESTIVAL_DESC= Include Festival Voice Synthesis Support
ERRORPOP_DESC= Send error popups to stderr
-BDB_DESC= Tiger Map Caching using Berkeley DB
MGG_DESC= Image library for raster map processing
IMAGICK_DESC= ImageMagick (Version 6)
GMAGICK_DESC= GraphicsMagick (Needs GCC to compile)
-OPTIONS_DEFAULT= BDB CURL GMAGICK
+OPTIONS_DEFAULT= CURL GMAGICK
DAVIS_CONFIGURE_ON= --enable-davis
@@ -84,8 +85,4 @@ FESTIVAL_CONFIGURE_WITH= festival
ERRORPOP_CONFIGURE_WITH= errorpopups
-BDB_USES= bdb
-BDB_CONFIGURE_ON= --with-bdb-incdir=${BDB_INCLUDE_DIR} \
- --with-bdb-libdir=${BDB_LIB_DIR}
-
.include <bsd.port.mk>