aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:45:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:46:12 +0000
commit2432d929bc16302b89d4869536aece43389204e4 (patch)
tree2e19c9b758ba04d501af70c9b65a419365c2c785
parentb95416f60aa11688281c2f10ee10a9f8a93ee714 (diff)
downloadports-2432d929bc16302b89d4869536aece43389204e4.tar.gz
ports-2432d929bc16302b89d4869536aece43389204e4.zip
cad/appcsxcad: New port: Minimal GUI Application using the QCSXCAD library
-rw-r--r--cad/Makefile1
-rw-r--r--cad/appcsxcad/Makefile42
-rw-r--r--cad/appcsxcad/distinfo3
-rw-r--r--cad/appcsxcad/pkg-descr3
4 files changed, 49 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 31eade51e9f5..dcc804239173 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -6,6 +6,7 @@
SUBDIR += admesh
SUBDIR += adms
SUBDIR += alliance
+ SUBDIR += appcsxcad
SUBDIR += archimedes
SUBDIR += astk-client
SUBDIR += astk-serveur
diff --git a/cad/appcsxcad/Makefile b/cad/appcsxcad/Makefile
new file mode 100644
index 000000000000..bd3f82a76564
--- /dev/null
+++ b/cad/appcsxcad/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= appcsxcad
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.2-7
+DISTVERSIONSUFFIX= -gde8c271
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Minimal GUI Application using the QCSXCAD library
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+# many dependencies below are induced by vtk8, but not vtk9
+LIB_DEPENDS= \
+ libCSXCAD.so:cad/csxcad \
+ libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2 \
+ libhdf5.so:science/hdf5 \
+ libpng16.so:graphics/png \
+ libQCSXCAD.so:cad/qcsxcad \
+ libsz.so:science/szip \
+ libtiff.so:graphics/tiff \
+ libvtkCommonCore-8.2.so:math/vtk8 # some related packages don't support vtk9 yet, see https://github.com/thliebig/QCSXCAD/issues/6#issuecomment-901633240
+
+USES= cmake jpeg pkgconfig qt:5 xorg
+USE_QT= core gui sql widgets xml buildtools_build qmake_build
+USE_XORG= ice sm x11 xext xt
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= thliebig
+GH_PROJECT= AppCSXCAD
+
+CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
+
+PLIST_FILES= bin/AppCSXCAD \
+ bin/AppCSXCAD.sh
+
+post-install:
+ @${REINPLACE_CMD} -i '' -e 's|#!/bin/bash|#!/bin/sh|' ${STAGEDIR}${PREFIX}/bin/AppCSXCAD.sh
+
+.include <bsd.port.mk>
diff --git a/cad/appcsxcad/distinfo b/cad/appcsxcad/distinfo
new file mode 100644
index 000000000000..621713981ddb
--- /dev/null
+++ b/cad/appcsxcad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629333844
+SHA256 (thliebig-AppCSXCAD-v0.2.2-7-gde8c271_GH0.tar.gz) = 68587ca7609f9cf85d0774d5809ad3dc43363cc3cde67581cb3c439a5a8bdf0f
+SIZE (thliebig-AppCSXCAD-v0.2.2-7-gde8c271_GH0.tar.gz) = 18749
diff --git a/cad/appcsxcad/pkg-descr b/cad/appcsxcad/pkg-descr
new file mode 100644
index 000000000000..a90b92a22530
--- /dev/null
+++ b/cad/appcsxcad/pkg-descr
@@ -0,0 +1,3 @@
+AppCSXCAD is a minimal application using the QCSXCAD library.
+
+WWW: https://github.com/thliebig/AppCSXCAD