aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-02-19 02:24:06 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-02-19 03:48:56 +0000
commit246082e073834b16b0721adc1234a2c340cd129d (patch)
tree829e2b2f09c76e20bf5ddf592e7b1bfbdd2cdfb2
parent73d09b68129793fe2801729f4e55b8d6c508917f (diff)
downloadports-246082e073834b16b0721adc1234a2c340cd129d.tar.gz
ports-246082e073834b16b0721adc1234a2c340cd129d.zip
databases/emacsql: Update to latest snapshot
This fixes runtime error of devel/{forge,forge-devel} While here, pet portlint and portclippy Changes: https://github.com/skeeto/emacsql/compare/3.0.0...3747260 MFH: 2022Q1 (cherry picked from commit 4aa107cc4566b0da08cfc6deac8fb50c0d59d106)
-rw-r--r--databases/emacsql/Makefile6
-rw-r--r--databases/emacsql/distinfo6
-rw-r--r--databases/emacsql/files/patch-emacsql-sqlite.el38
3 files changed, 29 insertions, 21 deletions
diff --git a/databases/emacsql/Makefile b/databases/emacsql/Makefile
index 53399e81cb54..8a440ccdca5e 100644
--- a/databases/emacsql/Makefile
+++ b/databases/emacsql/Makefile
@@ -1,6 +1,6 @@
PORTNAME= emacsql
-DISTVERSION= 3.0.0
-PORTREVISION= 2
+DISTVERSION= 3.0.0-17
+DISTVERSIONSUFFIX= -g3747260
CATEGORIES= databases elisp
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
@@ -23,6 +23,8 @@ MAKE_ENV+= LOAD_PATH="-L ${PREFIX}/${EMACS_SITE_LISPDIR} -L ${PREFIX}/${EMACS_VE
ALL_TARGET= binary compile
TEST_TARGET= check
+CONFLICTS_INSTALL= emacsql emacsql-emacs_*
+
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
diff --git a/databases/emacsql/distinfo b/databases/emacsql/distinfo
index 6322881961df..f69b0633f9df 100644
--- a/databases/emacsql/distinfo
+++ b/databases/emacsql/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621390677
-SHA256 (skeeto-emacsql-3.0.0_GH0.tar.gz) = 9d94be00518591c68cb0ed1de9dab885e35079f581fb0ae52af5af139a0f1088
-SIZE (skeeto-emacsql-3.0.0_GH0.tar.gz) = 2055251
+TIMESTAMP = 1645236638
+SHA256 (skeeto-emacsql-3.0.0-17-g3747260_GH0.tar.gz) = bf84d2e2d12191e8ee8695bb517a00ab74190d350df9eec6689516801b77a7a1
+SIZE (skeeto-emacsql-3.0.0-17-g3747260_GH0.tar.gz) = 2057124
diff --git a/databases/emacsql/files/patch-emacsql-sqlite.el b/databases/emacsql/files/patch-emacsql-sqlite.el
index 9c5d57f9e324..8ddae08ac1fe 100644
--- a/databases/emacsql/files/patch-emacsql-sqlite.el
+++ b/databases/emacsql/files/patch-emacsql-sqlite.el
@@ -1,19 +1,24 @@
---- emacsql-sqlite.el.orig 2018-10-31 17:50:07 UTC
+--- emacsql-sqlite.el.orig 2022-02-18 15:43:25 UTC
+++ emacsql-sqlite.el
-@@ -27,11 +27,7 @@
- (file-name-directory (or load-file-name buffer-file-name))
- "Directory where EmacSQL is installed.")
+@@ -33,16 +33,7 @@
+ "sqlite/emacsql-sqlite")
+ "Relative path to emacsql executable.")
-(defvar emacsql-sqlite-executable
-- (expand-file-name (if (memq system-type '(windows-nt cygwin ms-dos))
-- "sqlite/emacsql-sqlite.exe"
-- "sqlite/emacsql-sqlite")
-- emacsql-sqlite-data-root)
+- (expand-file-name emacsql-sqlite-executable-path
+- (if (or (file-writable-p emacsql-sqlite-data-root)
+- (file-exists-p (expand-file-name
+- emacsql-sqlite-executable-path
+- emacsql-sqlite-data-root)))
+- emacsql-sqlite-data-root
+- (expand-file-name
+- (concat "emacsql/" emacsql-version)
+- user-emacs-directory)))
+(defvar emacsql-sqlite-executable "%%PREFIX%%/bin/emacsql-sqlite"
"Path to the EmacSQL backend (this is not the sqlite3 shell).")
(defvar emacsql-sqlite-reserved
-@@ -82,6 +78,7 @@ http://www.sqlite.org/lang_keywords.html")
+@@ -100,6 +91,7 @@ used.")
(emacsql-wait connection)
(emacsql connection [:pragma (= busy-timeout $s1)]
(/ (* emacsql-global-timeout 1000) 2))
@@ -21,18 +26,19 @@
(emacsql-register connection)))
(cl-defun emacsql-sqlite (file &key debug)
-@@ -143,11 +140,11 @@ If called with non-nil ASYNC the return value is meani
- (let* ((cc (executable-find "cc"))
+@@ -163,12 +155,12 @@ If called with non-nil ASYNC the return value is meani
+ if path return it))
(src (expand-file-name "sqlite" emacsql-sqlite-data-root))
(files (mapcar (lambda (f) (expand-file-name f src))
- '("sqlite3.c" "emacsql.c")))
+ '("emacsql.c")))
(cflags (list (format "-I%s" src) (format "-O%d" (or o-level 2))))
- (ldlibs (if (memq system-type '(windows-nt berkeley-unix))
-- (list "-lm")
-- (list "-lm" "-ldl")))
-+ (list "-lm" "-lsqlite3")
-+ (list "-lm" "-ldl" "-lsqlite3")))
+ (ldlibs (cl-case system-type
+ (windows-nt (list))
+- (berkeley-unix (list "-lm"))
+- (otherwise (list "-lm" "-ldl"))))
++ (berkeley-unix (list "-lm" "-lsqlite3"))
++ (otherwise (list "-lm" "-ldl" "-lsqlite3"))))
(options (emacsql-sqlite-compile-switches))
(output (list "-o" emacsql-sqlite-executable))
(arguments (nconc cflags options files ldlibs output)))