aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:13:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:10 +0000
commit24bfd5932d0cfde2b58360c1655f65ddc9d07229 (patch)
tree8531575ec408a24962b75352dd431ccb141cc448
parentebf9671aafe639e8a0613516869668da8b22af0a (diff)
downloadports-24bfd5932d0cfde2b58360c1655f65ddc9d07229.tar.gz
ports-24bfd5932d0cfde2b58360c1655f65ddc9d07229.zip
textproc/py-spacy-llm: Add py-spacy-llm 0.7.1
Structured NLP with LLMs spacy-llm integrates Large Language Models (LLMs) into spaCy, featuring a modular system for fast prototyping and prompting, and turning unstructured responses into robust outputs for various NLP tasks, no training data required.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-spacy-llm/Makefile24
-rw-r--r--textproc/py-spacy-llm/distinfo3
-rw-r--r--textproc/py-spacy-llm/pkg-descr5
4 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 384fdade7f50..4580bdd05b85 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1559,6 +1559,7 @@
SUBDIR += py-snowballstemmer
SUBDIR += py-spacy
SUBDIR += py-spacy-legacy
+ SUBDIR += py-spacy-llm
SUBDIR += py-sparqlwrapper
SUBDIR += py-sphinx
SUBDIR += py-sphinx-argparse
diff --git a/textproc/py-spacy-llm/Makefile b/textproc/py-spacy-llm/Makefile
new file mode 100644
index 000000000000..4984b2f33afa
--- /dev/null
+++ b/textproc/py-spacy-llm/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= spacy-llm
+PORTVERSION= 0.7.1
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Integrate LLMs into structured NLP pipelines
+WWW= https://spacy.io/usage/large-language-models \
+ https://github.com/explosion/spacy-llm
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}confection>=0.1.3<1.0.0:devel/py-confection@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spacy>=3.5<4.0:textproc/py-spacy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-spacy-llm/distinfo b/textproc/py-spacy-llm/distinfo
new file mode 100644
index 000000000000..df4464cecce3
--- /dev/null
+++ b/textproc/py-spacy-llm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448856
+SHA256 (spacy-llm-0.7.1.tar.gz) = c59fe8fbf71aee1bc4243488ecdb7b7e9b3df81877d5e7ac661b899b658b73d6
+SIZE (spacy-llm-0.7.1.tar.gz) = 149795
diff --git a/textproc/py-spacy-llm/pkg-descr b/textproc/py-spacy-llm/pkg-descr
new file mode 100644
index 000000000000..f5921a98b4c1
--- /dev/null
+++ b/textproc/py-spacy-llm/pkg-descr
@@ -0,0 +1,5 @@
+Structured NLP with LLMs
+
+spacy-llm integrates Large Language Models (LLMs) into spaCy, featuring a
+modular system for fast prototyping and prompting, and turning unstructured
+responses into robust outputs for various NLP tasks, no training data required.