aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-21 19:52:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-21 19:53:29 +0000
commit25061ebc5fd2e9e3b13a63c7085b6637c03fb8ab (patch)
treed2e817ab640d1b95b3b1d8ee4b06879e52e7ea28
parent6062256f611b838fb760f2731f329c7d2d7d04bb (diff)
downloadports-25061ebc5fd2e9e3b13a63c7085b6637c03fb8ab.tar.gz
ports-25061ebc5fd2e9e3b13a63c7085b6637c03fb8ab.zip
audio/faust: Attempt to fix failure on riscv64
Reported by: fallout (cherry picked from commit 299eaaa88a7612ccd17243e2e889e2c62f009ead)
-rw-r--r--audio/faust/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/audio/faust/Makefile b/audio/faust/Makefile
index fa76f4dd0be1..e966f3f4fe8a 100644
--- a/audio/faust/Makefile
+++ b/audio/faust/Makefile
@@ -33,6 +33,7 @@ CMAKE_ARGS= -C ${FILESDIR}/backends.cmake -DLLVM_CONFIG=${LOCALBASE}/bin/llvm-co
CXXFLAGS+= -I${WRKSRC}/compiler/generator/cpp # fatal error: 'cpp_code_container.hh' file not found WHEN INCLUDE_STATIC=TRUE
CXXFLAGS+= `llvm-config${LLVM_VERSION} --cflags` -DLLVM_${LLVM_VERSION}0 # for the llvm backend
+CXXFLAGS_riscv64= -fPIC # attempt to fix failure: can't create dynamic relocation R_RISCV_HI20 against symbol: vtable for LV2UI in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= EXAMPLES HIGHLIGHT HTTPD_LIB