aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-18 16:03:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-18 18:52:37 +0000
commit250e12eac3d289cfbd999f42753d9e0af7e2d74e (patch)
tree58f9b662bfdf52402832892feb3f8d757442a0b7
parent0c49e6ff447e741f6e0569d4a9eda63e39d2eaf6 (diff)
downloadports-250e12eac3d289cfbd999f42753d9e0af7e2d74e.tar.gz
ports-250e12eac3d289cfbd999f42753d9e0af7e2d74e.zip
misc/dartsim: Update 6.12.2 -> 6.13.0
Reported by: portscout
-rw-r--r--misc/dartsim/Makefile9
-rw-r--r--misc/dartsim/distinfo6
-rw-r--r--misc/dartsim/files/patch-CMakeLists.txt23
-rw-r--r--misc/dartsim/files/patch-unittests_unit_test__IkFast.cpp11
-rw-r--r--misc/dartsim/pkg-plist85
5 files changed, 71 insertions, 63 deletions
diff --git a/misc/dartsim/Makefile b/misc/dartsim/Makefile
index b5110bb9d19f..f68448239dbe 100644
--- a/misc/dartsim/Makefile
+++ b/misc/dartsim/Makefile
@@ -1,7 +1,6 @@
PORTNAME= dartsim
DISTVERSIONPREFIX= v
-DISTVERSION= 6.12.2
-PORTREVISION= 3
+DISTVERSION= 6.13.0
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
@@ -13,7 +12,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= clang failure: https://bugs.llvm.org/show_bug.cgi?id=41757
-BUILD_DEPENDS= pagmo2>0:science/pagmo2
+BUILD_DEPENDS= pagmo2>0:science/pagmo2 \
+ pybind11>0:devel/pybind11
LIB_DEPENDS= libassimp.so:multimedia/assimp \
libBulletDynamics.so:devel/bullet \
libboost_system.so:devel/boost-libs \
@@ -21,6 +21,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libconsole_bridge.so:devel/ros-console_bridge \
libfcl.so:math/fcl \
libflann_cpp.so:math/flann \
+ libfmt.so:devel/libfmt \
libipopt.so:math/ipopt \
liblz4.so:archivers/liblz4 \
liboctomap.so:math/octomap \
@@ -32,7 +33,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
liburdfdom_world.so:devel/ros-urdfdom
USES= cmake compiler:c++17-lang eigen:3,build,run gl localbase:ldflags \
- pkgconfig xorg
+ pkgconfig python xorg
USE_GL= gl glu glut
USE_XORG= xi xmu
USE_CXXSTD= c++17 # missing in the project, it uses std::void_t (through pagmo2) which is a c++17 feature
diff --git a/misc/dartsim/distinfo b/misc/dartsim/distinfo
index d018f5b31b88..94ca0720c284 100644
--- a/misc/dartsim/distinfo
+++ b/misc/dartsim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659399352
-SHA256 (dartsim-dart-v6.12.2_GH0.tar.gz) = db1b3ef888d37f0dbc567bc291ab2cdb5699172523a58dd5a5fe513ee38f83b0
-SIZE (dartsim-dart-v6.12.2_GH0.tar.gz) = 15991464
+TIMESTAMP = 1674019885
+SHA256 (dartsim-dart-v6.13.0_GH0.tar.gz) = 4da3ff8cee056252a558b05625a5ff29b21e71f2995e6d7f789abbf6261895f7
+SIZE (dartsim-dart-v6.13.0_GH0.tar.gz) = 16035103
diff --git a/misc/dartsim/files/patch-CMakeLists.txt b/misc/dartsim/files/patch-CMakeLists.txt
index 0804e7bf1bf4..304a517ef529 100644
--- a/misc/dartsim/files/patch-CMakeLists.txt
+++ b/misc/dartsim/files/patch-CMakeLists.txt
@@ -1,24 +1,15 @@
---- CMakeLists.txt.orig 2021-07-15 08:12:45 UTC
+--- CMakeLists.txt.orig 2022-12-31 21:52:21 UTC
+++ CMakeLists.txt
-@@ -72,7 +72,7 @@ string(REGEX REPLACE "^<version>([0-9]+)\\.([0-9]+)\\.
- set(DART_VERSION "${DART_MAJOR_VERSION}.${DART_MINOR_VERSION}.${DART_PATCH_VERSION}")
-
- set(DART_PKG_DESC "Dynamic Animation and Robotics Toolkit.")
--set(DART_PKG_EXTERNAL_DEPS "eigen, ccd, fcl, assimp, boost")
-+set(DART_PKG_EXTERNAL_DEPS "eigen3, ccd, fcl, assimp")
-
- #===============================================================================
- # Build options
-@@ -213,7 +213,7 @@ elseif(CMAKE_COMPILER_IS_GNUCXX)
- if(GCC_VERSION VERSION_LESS 5.3.1)
- message(FATAL_ERROR "The installed g++ version is ${GCC_VERSION}. ${PROJECT_NAME} requires g++ 5.3.1 or greater.")
+@@ -242,7 +242,7 @@ elseif(CMAKE_COMPILER_IS_GNUCXX)
+ if(GCC_VERSION VERSION_LESS 7.3.0)
+ message(FATAL_ERROR "The installed g++ version is ${GCC_VERSION}. ${PROJECT_NAME} requires g++ 7.3.0 or greater.")
endif()
- set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
+ set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG")
set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-omit-frame-pointer -fno-inline-functions -fno-inline-functions-called-once -fno-optimize-sibling-calls")
if(DART_FAST_DEBUG)
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O1")
-@@ -243,7 +243,7 @@ elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
+@@ -270,7 +270,7 @@ elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
if("${CMAKE_SYSTEM_NAME}" MATCHES "Darwin")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
endif()
@@ -27,9 +18,9 @@
set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-omit-frame-pointer -fno-inline-functions -fno-optimize-sibling-calls")
if(DART_FAST_DEBUG)
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O1")
-@@ -312,20 +312,20 @@ if(TARGET dart)
+@@ -338,20 +338,20 @@ if(TARGET dart)
if(MSVC)
- # add_subdirectory(examples)
+ add_subdirectory(examples)
else()
- add_subdirectory(examples EXCLUDE_FROM_ALL)
- get_property(examples GLOBAL PROPERTY DART_EXAMPLES)
diff --git a/misc/dartsim/files/patch-unittests_unit_test__IkFast.cpp b/misc/dartsim/files/patch-unittests_unit_test__IkFast.cpp
deleted file mode 100644
index 57947fa312cd..000000000000
--- a/misc/dartsim/files/patch-unittests_unit_test__IkFast.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- unittests/unit/test_IkFast.cpp.orig 2021-07-15 08:12:45 UTC
-+++ unittests/unit/test_IkFast.cpp
-@@ -131,7 +131,7 @@ TEST(IkFast, LoadWamArmIk)
- ik->setHierarchyLevel(1);
- std::stringstream ss;
- ss << DART_SHARED_LIB_PREFIX << "GeneratedWamIkFast";
--#if (DART_OS_LINUX || DART_OS_MACOS) && !NDEBUG
-+#if (DART_OS_LINUX || DART_OS_FREEBSD || DART_OS_MACOS) && !NDEBUG
- ss << "d";
- #endif
- ss << "." << DART_SHARED_LIB_EXTENSION;
diff --git a/misc/dartsim/pkg-plist b/misc/dartsim/pkg-plist
index 975b36e81713..36fb9bed1a03 100644
--- a/misc/dartsim/pkg-plist
+++ b/misc/dartsim/pkg-plist
@@ -45,6 +45,8 @@ include/dart/collision/ode/OdeTypes.hpp
include/dart/collision/ode/ode.hpp
include/dart/common/Aspect.hpp
include/dart/common/AspectWithVersion.hpp
+include/dart/common/CAllocator.hpp
+include/dart/common/Castable.hpp
include/dart/common/ClassWithVirtualBase.hpp
include/dart/common/Cloneable.hpp
include/dart/common/Composite.hpp
@@ -54,15 +56,24 @@ include/dart/common/Deprecated.hpp
include/dart/common/EmbeddedAspect.hpp
include/dart/common/Empty.hpp
include/dart/common/Factory.hpp
+include/dart/common/Filesystem.hpp
+include/dart/common/FreeListAllocator.hpp
include/dart/common/IncludeWindows.hpp
include/dart/common/LocalResource.hpp
include/dart/common/LocalResourceRetriever.hpp
include/dart/common/LockableReference.hpp
+include/dart/common/Logging.hpp
+include/dart/common/Macros.hpp
include/dart/common/Memory.hpp
+include/dart/common/MemoryAllocator.hpp
+include/dart/common/MemoryAllocatorDebugger.hpp
+include/dart/common/MemoryManager.hpp
+include/dart/common/Metaprogramming.hpp
include/dart/common/NameManager.hpp
include/dart/common/Observer.hpp
include/dart/common/Optional.hpp
include/dart/common/Platform.hpp
+include/dart/common/PoolAllocator.hpp
include/dart/common/ProxyAspect.hpp
include/dart/common/RequiresAspect.hpp
include/dart/common/Resource.hpp
@@ -72,7 +83,10 @@ include/dart/common/Signal.hpp
include/dart/common/Singleton.hpp
include/dart/common/SmartPointer.hpp
include/dart/common/SpecializedForAspect.hpp
+include/dart/common/StlAllocator.hpp
include/dart/common/StlHelpers.hpp
+include/dart/common/Stopwatch.hpp
+include/dart/common/String.hpp
include/dart/common/Subject.hpp
include/dart/common/Timer.hpp
include/dart/common/Uri.hpp
@@ -82,6 +96,7 @@ include/dart/common/common.hpp
include/dart/common/detail/AlignedAllocator.hpp
include/dart/common/detail/Aspect.hpp
include/dart/common/detail/AspectWithVersion.hpp
+include/dart/common/detail/Castable-impl.hpp
include/dart/common/detail/Cloneable.hpp
include/dart/common/detail/Composite.hpp
include/dart/common/detail/CompositeData.hpp
@@ -90,7 +105,12 @@ include/dart/common/detail/ConnectionBody.hpp
include/dart/common/detail/EmbeddedAspect.hpp
include/dart/common/detail/Factory-impl.hpp
include/dart/common/detail/LockableReference-impl.hpp
+include/dart/common/detail/Logging-impl.hpp
include/dart/common/detail/Memory-impl.hpp
+include/dart/common/detail/MemoryAllocator-impl.hpp
+include/dart/common/detail/MemoryAllocatorDebugger-impl.hpp
+include/dart/common/detail/MemoryManager-impl.hpp
+include/dart/common/detail/Metaprogramming-impl.hpp
include/dart/common/detail/NameManager.hpp
include/dart/common/detail/NoOp.hpp
include/dart/common/detail/ProxyAspect.hpp
@@ -99,6 +119,8 @@ include/dart/common/detail/SharedLibraryManager.hpp
include/dart/common/detail/Signal.hpp
include/dart/common/detail/Singleton-impl.hpp
include/dart/common/detail/SpecializedForAspect.hpp
+include/dart/common/detail/StlAllocator-impl.hpp
+include/dart/common/detail/Stopwatch-impl.hpp
include/dart/common/detail/TemplateJoinerDispatchMacro.hpp
include/dart/common/detail/sub_ptr.hpp
include/dart/common/sub_ptr.hpp
@@ -111,6 +133,7 @@ include/dart/constraint/ConstrainedGroup.hpp
include/dart/constraint/ConstraintBase.hpp
include/dart/constraint/ConstraintSolver.hpp
include/dart/constraint/ContactConstraint.hpp
+include/dart/constraint/ContactSurface.hpp
include/dart/constraint/DantzigBoxedLcpSolver.hpp
include/dart/constraint/DantzigLCPSolver.hpp
include/dart/constraint/DynamicJointConstraint.hpp
@@ -126,7 +149,7 @@ include/dart/constraint/SmartPointer.hpp
include/dart/constraint/SoftContactConstraint.hpp
include/dart/constraint/WeldJointConstraint.hpp
include/dart/constraint/constraint.hpp
-include/dart/constraint/detail/BoxedLcpSolver-impl.hpp
+include/dart/constraint/detail/ConstraintSolver-impl.hpp
include/dart/dart.hpp
include/dart/dynamics/ArrowShape.hpp
include/dart/dynamics/AssimpInputResourceAdaptor.hpp
@@ -215,6 +238,7 @@ include/dart/dynamics/detail/InverseKinematicsPtr.hpp
include/dart/dynamics/detail/JointAspect.hpp
include/dart/dynamics/detail/JointPtr.hpp
include/dart/dynamics/detail/MarkerAspect.hpp
+include/dart/dynamics/detail/MetaSkeleton-impl.hpp
include/dart/dynamics/detail/Node.hpp
include/dart/dynamics/detail/NodeManagerJoiner.hpp
include/dart/dynamics/detail/NodePtr.hpp
@@ -222,7 +246,6 @@ include/dart/dynamics/detail/PlanarJointAspect.hpp
include/dart/dynamics/detail/PrismaticJointAspect.hpp
include/dart/dynamics/detail/RevoluteJointAspect.hpp
include/dart/dynamics/detail/ScrewJointAspect.hpp
-include/dart/dynamics/detail/Shape.hpp
include/dart/dynamics/detail/ShapeFrameAspect.hpp
include/dart/dynamics/detail/ShapeNode.hpp
include/dart/dynamics/detail/Skeleton.hpp
@@ -288,6 +311,8 @@ include/dart/gui/osg/TrackballManipulator.hpp
include/dart/gui/osg/Utils.hpp
include/dart/gui/osg/Viewer.hpp
include/dart/gui/osg/WorldNode.hpp
+include/dart/gui/osg/detail/CameraModeCallback.hpp
+include/dart/gui/osg/detail/Utils-impl.hpp
include/dart/gui/osg/osg.hpp
include/dart/gui/osg/render/BoxShapeNode.hpp
include/dart/gui/osg/render/CapsuleShapeNode.hpp
@@ -367,6 +392,7 @@ include/dart/utils/PackageResourceRetriever.hpp
include/dart/utils/SkelParser.hpp
include/dart/utils/VskParser.hpp
include/dart/utils/XmlHelpers.hpp
+include/dart/utils/detail/XmlHelpers-impl.hpp
include/dart/utils/mjcf/MjcfParser.hpp
include/dart/utils/mjcf/mjcf.hpp
include/dart/utils/sdf/SdfParser.hpp
@@ -378,48 +404,48 @@ include/dart/utils/urdf/urdf.hpp
include/dart/utils/urdf/urdf_world_parser.hpp
include/dart/utils/utils.hpp
lib/libdart-collision-bullet.so
-lib/libdart-collision-bullet.so.6.12
-lib/libdart-collision-bullet.so.6.12.2
+lib/libdart-collision-bullet.so.6.13
+lib/libdart-collision-bullet.so.6.13.0
lib/libdart-collision-ode.so
-lib/libdart-collision-ode.so.6.12
-lib/libdart-collision-ode.so.6.12.2
+lib/libdart-collision-ode.so.6.13
+lib/libdart-collision-ode.so.6.13.0
lib/libdart-external-imgui.so
-lib/libdart-external-imgui.so.6.12
-lib/libdart-external-imgui.so.6.12.2
+lib/libdart-external-imgui.so.6.13
+lib/libdart-external-imgui.so.6.13.0
lib/libdart-external-lodepng.so
-lib/libdart-external-lodepng.so.6.12
-lib/libdart-external-lodepng.so.6.12.2
+lib/libdart-external-lodepng.so.6.13
+lib/libdart-external-lodepng.so.6.13.0
lib/libdart-external-odelcpsolver.so
-lib/libdart-external-odelcpsolver.so.6.12
-lib/libdart-external-odelcpsolver.so.6.12.2
+lib/libdart-external-odelcpsolver.so.6.13
+lib/libdart-external-odelcpsolver.so.6.13.0
lib/libdart-gui-osg.so
-lib/libdart-gui-osg.so.6.12
-lib/libdart-gui-osg.so.6.12.2
+lib/libdart-gui-osg.so.6.13
+lib/libdart-gui-osg.so.6.13.0
lib/libdart-gui.so
-lib/libdart-gui.so.6.12
-lib/libdart-gui.so.6.12.2
+lib/libdart-gui.so.6.13
+lib/libdart-gui.so.6.13.0
lib/libdart-optimizer-ipopt.so
-lib/libdart-optimizer-ipopt.so.6.12
-lib/libdart-optimizer-ipopt.so.6.12.2
+lib/libdart-optimizer-ipopt.so.6.13
+lib/libdart-optimizer-ipopt.so.6.13.0
lib/libdart-optimizer-nlopt.so
-lib/libdart-optimizer-nlopt.so.6.12
-lib/libdart-optimizer-nlopt.so.6.12.2
+lib/libdart-optimizer-nlopt.so.6.13
+lib/libdart-optimizer-nlopt.so.6.13.0
lib/libdart-planning.so
-lib/libdart-planning.so.6.12
-lib/libdart-planning.so.6.12.2
+lib/libdart-planning.so.6.13
+lib/libdart-planning.so.6.13.0
lib/libdart-utils-urdf.so
-lib/libdart-utils-urdf.so.6.12
-lib/libdart-utils-urdf.so.6.12.2
+lib/libdart-utils-urdf.so.6.13
+lib/libdart-utils-urdf.so.6.13.0
lib/libdart-utils.so
-lib/libdart-utils.so.6.12
-lib/libdart-utils.so.6.12.2
+lib/libdart-utils.so.6.13
+lib/libdart-utils.so.6.13.0
lib/libdart.so
-lib/libdart.so.6.12
-lib/libdart.so.6.12.2
+lib/libdart.so.6.13
+lib/libdart.so.6.13.0
+%%PYTHON_SITELIBDIR%%/dartpy%%PYTHON_EXT_SUFFIX%%.so
libdata/pkgconfig/dart.pc
%%DATADIR%%/cmake/DARTConfig.cmake
%%DATADIR%%/cmake/DARTConfigVersion.cmake
-%%DATADIR%%/cmake/DARTFindBoost.cmake
%%DATADIR%%/cmake/DARTFindBullet.cmake
%%DATADIR%%/cmake/DARTFindEigen3.cmake
%%DATADIR%%/cmake/DARTFindGLUT.cmake
@@ -432,6 +458,7 @@ libdata/pkgconfig/dart.pc
%%DATADIR%%/cmake/DARTFindccd.cmake
%%DATADIR%%/cmake/DARTFindfcl.cmake
%%DATADIR%%/cmake/DARTFindflann.cmake
+%%DATADIR%%/cmake/DARTFindfmt.cmake
%%DATADIR%%/cmake/DARTFindlz4.cmake
%%DATADIR%%/cmake/DARTFindoctomap.cmake
%%DATADIR%%/cmake/DARTFindtinyxml2.cmake