aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-10-12 14:12:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-10-12 17:37:02 +0000
commit25c086d471f0b56beaf8f6458c40e313033f6e31 (patch)
tree99bfcd5888315d37bc7bedd3418eee6a104b57e0
parent066252a3eb8d6e3f033cdb196f7d2f4fbcab38f2 (diff)
downloadports-25c086d471f0b56beaf8f6458c40e313033f6e31.tar.gz
ports-25c086d471f0b56beaf8f6458c40e313033f6e31.zip
devel/love*: fix conflicts
Make DOCSDIR dependent on PKGNAMESUFFIX for all love* ports to avoid conflicts. While here, sincence a couple of MKDIRs. PR: 257008 Submitted by: dufresnep@zoho.com
-rw-r--r--devel/love/Makefile1
-rw-r--r--devel/love07/Makefile2
-rw-r--r--devel/love08/Makefile5
-rw-r--r--devel/love10/Makefile3
-rw-r--r--devel/love5/Makefile4
5 files changed, 9 insertions, 6 deletions
diff --git a/devel/love/Makefile b/devel/love/Makefile
index f00d7bab1029..e0fdede67354 100644
--- a/devel/love/Makefile
+++ b/devel/love/Makefile
@@ -30,6 +30,7 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
INSTALL_TARGET= install-strip
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= *
OPTIONS_DEFINE= DOCS LUAJIT GME
diff --git a/devel/love07/Makefile b/devel/love07/Makefile
index 42e5be3f821e..7ae653a98c31 100644
--- a/devel/love07/Makefile
+++ b/devel/love07/Makefile
@@ -37,7 +37,7 @@ DOS2UNIX_FILES= src/modules/graphics/opengl/GLee.h
PLIST_FILES= bin/love07
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}07
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
diff --git a/devel/love08/Makefile b/devel/love08/Makefile
index 68b17c635cef..a4724ac81787 100644
--- a/devel/love08/Makefile
+++ b/devel/love08/Makefile
@@ -1,6 +1,6 @@
PORTNAME= love
PORTVERSION= 0.8.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= devel games
MASTER_SITES= http://cdn.bitbucket.org/rude/love/downloads/ \
http://mirror.amdmi3.ru/distfiles/
@@ -35,6 +35,7 @@ DOS2UNIX_FILES= src/modules/graphics/opengl/GLee.h
PLIST_FILES= bin/love08
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
@@ -46,7 +47,7 @@ post-patch:
${WRKSRC}/configure
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in changes.txt readme.md
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/devel/love10/Makefile b/devel/love10/Makefile
index b490ea0839db..373463e70523 100644
--- a/devel/love10/Makefile
+++ b/devel/love10/Makefile
@@ -1,6 +1,6 @@
PORTNAME= love
PORTVERSION= 0.10.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel games
MASTER_SITES= https://bitbucket.org/rude/love/downloads/ \
http://mirror.amdmi3.ru/distfiles/
@@ -32,6 +32,7 @@ CONFIGURE_ARGS= --program-suffix=${PKGNAMESUFFIX}
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
INSTALL_TARGET= install-strip
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= *
OPTIONS_DEFINE= DOCS LUAJIT
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index 3cd696fce0ec..5778dec677a6 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -26,7 +26,7 @@ DOS2UNIX_FILES= src/system/love_system.cpp
PLIST_FILES= bin/love5
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}5
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
@@ -39,7 +39,7 @@ post-patch:
${WRKSRC}/configure
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in changes.txt readme.txt
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor